1

I can't figure this out. I have 2 HP 2910 switches, interlinked (A1). VLAN 113 is management, I have an uplink to the core switch on port 20. Pinging and browsing works fine. However, I can't ping a storage device in VLAN 114. Other connected devices: StoreVirtual devices, ESXi hosts.

I can ping the management IP of the switch (on vlan 113) until I try to tag port 20 ( VLAN 114 - storage ). This only happens with VLAN 114, I tried another VLAN and the issue did not occur.

Config:

; J9145A Configuration Editor; Created on release #W.14.38

hostname "SAN-SW-01"
module 1 type J9145A
module 2 type J9165A
module 3 type J9008A
ip default-gateway 10.3.13.254
vlan 1
   name "DEFAULT_VLAN"
   no untagged 1-24,A1,B1-B2
   no ip address
   exit
vlan 112
   name "112_ESX"
   ip address 10.3.12.121 255.255.255.0
   exit
vlan 114
   name "Storage"
   untagged 1-19,22-24
   tagged 21,A1,B1-B2
   no ip address
   exit
vlan 113
   name "Management"
   ip address 10.3.13.98 255.255.255.0
   tagged 20-21,A1,B1-B2
   exit
snmp-server community "GlOyS39" unrestricted
snmp-server contact "IT Dienst Izegem"
loop-protect 1-19,21-24,A1,B1-B2
loop-protect disable-timer 3600
no autorun

I can't figure it out, since this configuration on a smaller independent switch does work. I can still ping/browse the management IP. I don't get it why it's a problem above but not with the small switch. Also quite surprised by the order of VLAN 113, 114 above, unsure why it's not in the right order - might that be the problem? Testing is difficult since these are the only 2 switches with that kind of interlink in my network and they are at a critical spot (storage).

; J9774A Configuration Editor; Created on release #YA.15.12.0007
; Ver #04:01.ff.37.27:ea
hostname "HP-2530-8G-PoEP"
ip default-gateway 10.3.13.254
snmp-server community "public" unrestricted
vlan 1
   name "DEFAULT_VLAN"
   no untagged 1-10
   no ip address
   exit
vlan 113
   name "Management_New"
   tagged 10
   ip address 10.3.13.99 255.255.255.0
   exit
vlan 114
   name "VLAN114"
   untagged 1-9
   tagged 10
   no ip address
   exit

Core switch is tagged 113, 114 and some other VLANs (permit all tagged).

Ports in use on this switch for storage (the second storage switch linked through A1 is more or less the same for redundancy )

01/04   01  down link   Storage System  StoreVirtual 2 - san-prod02
01/06   04  down link   Storage System  StoreVirtual 2 - san-prod02
01/08   03  down link   Storage System  StoreVirtual 1 - san-prod01
01/10   02  down link   Storage System  StoreVirtual 1 - san-prod01
01/12   04/04   down link   Server  ESX Server 2 - vmw02
01/14   03/04   down link   Server  ESX Server 1 - vmw01
01/16   03/04   down link   Server  ESX Server 4 - vmw04
01/18   03/04   down link   Server  ESX Server 3 - vmw03
01/19   02  down link   Server  bckp01
A1  A1  up link Network Device  SAN-SW-02
  • However, I can't ping a storage device in VLAN 114 - can't ping from where? I can ping the management IP of the switch (on vlan 113) until I try to tag port 20 ( VLAN 114 - storage ) - can ping from where, until you tag port 20 on what interfaces? – TessellatingHeckler Apr 4 '17 at 15:12
  • Maybe both 20 and 21 ports are connected to the core switch directly or via another switches. I think you have a ring in your network. What about STP and logs on the core switch can you​ tell? – Mikhail Khirgiy Apr 4 '17 at 15:48
  • Why is there no IP address for VLAN 114? – jftuga Apr 4 '17 at 18:38
  • What is store? What about logs on switches? – Mikhail Khirgiy Apr 4 '17 at 18:41
  • Except for the core switch, each client switch only has an IP address defined on the management VLAN 113. StoreVirtual is a HPE product, it's a storage system. – jbostoen Apr 4 '17 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.