-1

Since I already spend around 30 hours on research and trying around, I need your help...

I'm trying to virtualize my firewall/router (pfSense) on a Hyper-V machine. This worked perfectly when I was still running VMWare Esxi.

But for some odd reason, I get random package loss on my new server. The hardware is exactly the same. I have 3 NICs, one dedicated to WAN, one dedicated to LAN (VMs) and one dedicated for the server itself for management purposes.

My pfSense can talk to the WAN perfectly fine, but from time to time (usually every 2-3 minutes) I get 1 minute of no WAN connection at all. My pfsense shows "package drop" and then "disconnected" (only on the WAN interface).

I already checked if its my modems fault, it isn't. My network is working perfectly fine with an old router.

The pfSense is configured correctly (I assume).

I already tried the following:

  • Disabling LSO on the NICs (both WAN & LAN, and both physical and virtual)
  • Disabled hardware checksum offload in the pfSense
  • Set optimization mode to conservative in pfsense
  • disabling VMQ in hyper-v settings
  • updating the NIC driver on windows

...and of course a lot more, but to be honest, I can't remeber it all.

So, any advice is appreciated!!!

0

I'm running into the same issues with about 5% packet loss. What version of PFsense are you using? We have taken close the exact same steps.

  • To be honest I'd have to look but I guess I've got the newest version. I just downloaded and installed it last week. – Florian Traun Apr 9 '17 at 14:35
  • Well... I'm almost embarrassed to admit what the problem actually was. We had a test VM with the same IP as the production that was mistakenly powered on. Removed the NIC from the test system and am running without loss. – A Peck Apr 9 '17 at 14:49
  • I'd be a lucky man if that would be the problem ...:( – Florian Traun Apr 9 '17 at 14:56
  • Did you try disabling the gateway check? – A Peck Apr 9 '17 at 18:33
  • where do you do that? – Florian Traun Apr 9 '17 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.