0

When I send an email via my smtp exim4 server, I get this error:

The sender address blah@usersdomain@myserver.net is not\n553 5.1.2 a valid RFC-5321 address.

Logins to the server are with full email address. But exim4 just concatenates the user login with my primary_hostname to get this debacle. How can I change this?

  • @ isn't a valid character in a Unix user name. source – rustyx Apr 8 '17 at 20:33
  • That was the issue. But I'll post the answer in a minute. – J. Martin Apr 23 '17 at 6:21
0

The answer to this question is:

acl_check_rcpt:
  ... your stuff here, then abit later towards the end of the ACL
  accept  
    authenticated = *
    # JolieRouge This took some time to search out
    # 2006-09-27 <pille@struction.de>
    # force empty domain, when fixing header during submission, as we use fqdn in our usernames (to avoid doubled domains)
    # 2007-01-30 <pille@struction.de>
    # added /sender_retain option to take any given address from 'Sender:'-header (used as 'Return-path:' and for 'MAIL FROM:'-SMTP-command)
    control       = submission/sender_retain/domain=

The bottom line control = submission/sender_retain/domain= is used when your logins are a full email address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.