5

I'm trying to make a media server with Samba, but I don't need or want mangled names, so I disabled that in smb.conf. (I'm not expecting any Windows clients to connect.) However, when I do this, those files that were mangled just disappear. This is what the directory should contain:

Chorale Prelude "Ein feste Burg ist unser Gott", BWV 720.flac
Chorale Prelude "Nun freut euch, lieben Cristen", BWV 734a.flac
Chorale Prelude "Wachet auf, ruft uns die Stimme", BWV 645.flac
Fantasia and Fugue in G minor, BWV 542 "The Great": II. Fugue.flac
folder.jpg
Fugue in G major, BWV 571 "The Jig".flac
Fugue in G minor, BWV 578 "The Little".flac
Passacaglia and Fugue in C minor, BWV 582: II. Fugue.flac
Passacaglia and Fugue in C minor, BWV 582: I. Passacaglia.flac
Toccata, Adagio, and Fugue in C major, BWV 564: II. Adagio.flac
Toccata, Adagio, and Fugue in C major, BWV 564: III. Fugue.flac
Toccata, Adagio, and Fugue in C major, BWV 564: I. Toccata.flac
Toccata and Fugue in D minor, BWV 565: I. Fugue.flac
Toccata and Fugue in D minor, BWV 565: I. Toccata.flac
Toccata in F major, BWV 540.flac

With mangled names disabled, this is what is visible from an Ubuntu client:

folder.jpg
Toccata in F major, BWV 540.flac

And this is my smb.conf:

[global]

security = user
map to guest = bad user
guest account = nobody

mangled names = no

[T&S Media Server]

path = /media/shadow-mini
only guest = yes
guest ok = yes

I have tried adding the lines unix charset = UTF-8, dos charset = CP850, and hide special file = no to no avail.

In other words, disabling mangled names just makes those files disappear from the client.

How can I still see all the files with their original names on Samba?

2
+100

From the Samba documentation on the config option mangled names which you mention:

This share-level option specifies whether Samba will mangle filenames for 8.3 clients. If the option is set to no, Samba will not mangle the names, and (depending on the client) they will either be invisible or appear truncated to those using 8.3 operating systems. The default value is yes. You can override it per share as follows:

[data]
    mangled names = no

From this we can infer that your client is choosing not to show files with filenames which would match mangling rules.

I suggest checking what characters your client can deal with and then update the samba configuration on the server with the appropriate config flags accordingly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy