0

I have installed cacti to monitor my system. Installation was easy, and everything went right.

But when I tried to access 127.0.0.1/cacti I get this error

enter image description here

It is my first time on apache, Please help to get rid of this error.

This is the conf file,

Alias /cacti /usr/share/cacti/site

<Directory /usr/share/cacti/site>
    Options +FollowSymLinks
    AllowOverride None
    <IfVersion >= 2.3>
            Require all granted
    </IfVersion>
    <IfVersion < 2.3>
            Order Allow,Deny
            Allow from all
    </IfVersion>

    AddType application/x-httpd-php .php

    <IfModule mod_php.c>
            php_flag magic_quotes_gpc Off
            php_flag short_open_tag On
            php_flag register_globals Off
            php_flag register_argc_argv On
            php_flag track_vars On
            # this setting is necessary for some locales
            php_value mbstring.func_overload 0
            php_value include_path .
    </IfModule>

    DirectoryIndex index.php
</Directory>

This file was automatically created during the installation process. I installed it from here, https://www.server-world.info/en/note?os=Ubuntu_16.04&p=cacti

  • 1
    please add a comment before down voting, how can I improve it ? – Luv33preet Apr 10 '17 at 20:32
  • 2
    This error is nothing to do with Apache. Your PHP instance has been compiled without the xml extension for some reason. How did you install php? – Joe Niland Apr 11 '17 at 4:03
  • @JoeNiland you have made the right answer, I suggest you add it to the answer section directly instead of comment. – ezra-s Apr 11 '17 at 6:46
1

Package php-xml is not installed on your system. Install it using package manager (apt, yum etc).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.