0

I started with a fresh install of RHEL 6, and it created a default swap as a logical volume (/dev/vg_hostname/lv_swap), along with the root (/dev/vg_hostname/lv_root) mounted as /

I then created a separate swap partition on it's own disk (/dev/sdb), deactivating the old swap and then enabling the new swap. Modified the fstab to accomidate, rebooted and verified that the new swap was active, and the old swap was no longer in effect.

# cat /proc/swaps
Filename                                Type            Size    Used    Priority
/dev/dm-2                               partition       8384508 0       -1

So, what's giving me trouble is removing the logical volume (/dev/vg_hostname/lv_swap), and return that now unused space in the volume group to the root logical volume (/dev/vg_hostname/lv_root)

I used these steps, which I thought should be fairly strait forward.

make the volume no longer active...

# lvremove /dev/vg_sierrastaging/lv_swap
  Logical volume "lv_swap" successfully removed

At this point, I reboot the system. I don't see any messages behind the splash screen (alt + d) and then the boot hangs (flashing caps lock and the scroll locks buttons on the keyboard)

Am I just totally missing something here with removing this logical volume, or is there a deeper issue here?

I have contacted Red Hat support, and they haven't been very helpful with providing any type of answer... one suggestion from the engineer was to re-build the intramfs, which I did according to their instructions, but that didn't seem to solve this issue either.

Any help or suggestions would be greatly appreciated!

Update

Looks like with Red Hat 6, there's a kernel option in the /boot/grub/grub.conf file that specifically references the swap space that was created when they system was installed ... here's the option : rd_LVM_LV=vg_sierrastaging/lv_root rd_LVM_LV=vg_sierrastaging/lv_swap

So, I removed that option, and was then able to restart the server without that swap partition being active.

Maybe someone can explain why that's a kernel option, or if I should need to put the different swap partition into the grub.conf file as a separate kernel option.

  • Did you remove the swap entry from /etc/fstab? – HBruijn Apr 13 '17 at 13:50
  • I did... here's the lines from the /etc/fstab .. here are the lines from fstab ... # old swap #/dev/mapper/vg_sierrastaging-lv_swap swap swap defaults 0 0 # new swap --attached drive /dev/vgswap/lvswap swap swap defaults 0 0 – ray_voelker Apr 13 '17 at 13:55
  • Can you boot from install cd/dvd in rescue mode and do command lsblk? – Mikhail Khirgiy Apr 13 '17 at 19:33
  • 1
    Please don't add information in comments. Instead, click "edit" and add the information (properly formatted) into the question. – Jenny D Apr 14 '17 at 10:49
  • rd_LVM_LV tells dracut which logical volumes need to be activated before switching root - at least the device containing your root FS must be there. Swap should not be necessary. – Martian Apr 20 '17 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.