0

I have a Domain Name with 123-reg that is using their name servers, and I have two A records for this Domain Name that point to my Windows VPS.

In my VPS, I then have IIS running the default site with bindings for * and www. This works for http://www.example.com. However, when trying http://example.com, it says the DNS records couldn't be found.

EDIT: The below possible duplicate isn't correct as that question has www.example.com pointing to a different IP that example.com, whereas mine isn't working at all. Trust me, I've already looked.

  • It sounds as though your issue might indeed by DNS, and as though your question might be a duplicate of serverfault.com/questions/381741/…. The short version is: from your description, you indeed do not seem to have an A record for example.com, but only for www, and for any other subdomains (i.e. the www is redundant, because it is part of *.example.com). The fix should be creating the missing DNS record for your actual domain, e.g. example.com in A [IP] – iwaseatenbyagrue Apr 15 '17 at 11:59
  • Yes but the problem here @iwaseatenbyagrue is that I can only add subdomain names for A records (so I can't add 'domain.co.uk' to route it to my VPS, I can only add 'www' or 'subdomain'.). I already tried the wildcard but it just sends everything apart from domain.co.uk to it – TechnicalTophat Apr 15 '17 at 12:02
  • OK - can you create a CNAME for example.com? If so, just point it to your www record. If you can't do that either, then I am not sure how you can fix this: you really would need 'full' access to your DNS settings. – iwaseatenbyagrue Apr 15 '17 at 12:04
  • @iwaseatenbyagrue nope just tried it >:( – TechnicalTophat Apr 15 '17 at 12:07
3

You skipped phases 4-5 in the 123-reg FAQ: How do I set up my DNS for Web forwarding? manual.

  1. Login to your 123-reg control panel.

  2. In the Domain names section, select the relevant domain name in the drop-down list and click on the Manage button.

  3. Click on the Manage DNS (A, MX, CNAME, TXT) link.

  4. On the Advanced DNS tab, click the edit button and change the IP next to the @ type A record to 94.136.40.82

  5. Click on the Save button.

  6. Repeat Steps 4 and 5 for the www type A record.

Of course this works the same way whether you use their web forwarding or your own IP.

As RFC 1035, 5.1 defines, @ is used to denote the current $ORIGIN, defined earlier in the zone file.

You don't see it in your web based configuration tool, but as you set the other hostnames without the origin, e.g. www instead of www.example.com., it suggests example.com. is your $ORIGIN and you can refer to it with just @ IN A.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.