0

I'm setting up rDNS for use with a SolusVM server. I used PowerDNS on two servers for a slave and a master, and set up the MySQL replication successfully. When viewing the MySQL records table, I see the SOA, NS, and PTR records all there.

I've created two A records (rdns1.example.com, rdns2.example.com) and pointed them to the master and slave respectively.

I updated the IP reverse DNS nameservers on arin.net to point to the rdns1.example.com and rdns2.example.com

If I run 'host 146.71.84.4', it returns:

 Host 4.84.71.146.in-addr.arpa not found: 2(SERVFAIL)

If I run 'dig -x 146.71.84.4', it returns:

 ; <<>> DiG 9.9.5-9+deb8u10-Debian <<>> 146.71.84.4
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 41971
 ;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

 ;; OPT PSEUDOSECTION:
 ; EDNS: version: 0, flags:; udp: 4096
 ;; QUESTION SECTION:
 ;146.71.84.4.                   IN      A

 ;; AUTHORITY SECTION:
 .                       73327   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2017041600 1800 900 604800 86400

 ;; Query time: 14 msec
 ;; SERVER: 50.116.35.5#53(50.116.35.5)
 ;; WHEN: Sun Apr 16 09:07:33 UTC 2017
 ;; MSG SIZE  rcvd: 115
8
  • The dig output looks to be from that command but without -x Apr 16 '17 at 9:32
  • Neither server appears to be responding at all, is it running? Firewall? Apr 16 '17 at 9:36
  • I don't think I mentioned it in the question, the IPs for the PowerDNS master/server are 146.71.84.43 and 146.71.84.44 respectively if that was your question. No firewalls and they're running.
    – Liam Smith
    Apr 16 '17 at 9:37
  • Then how come neither of them responds at all? Apr 16 '17 at 9:38
  • Not responding to a ping? That's odd, it's responding to both my home computer and online ping tools
    – Liam Smith
    Apr 16 '17 at 9:41
1

Neither nameserver was responding to queries at all.

Ensure that the nameserver software is running (check logs if not starting) and that no firewall is interfering.

2
  • You are amazing! The issue was multiple launch= statements in the powerdns config preventing it from running correctly/at all. SolusVM rdns guide doesn't mention that you need to replace it. Thank you so much!
    – Liam Smith
    Apr 16 '17 at 10:02
  • Just for the record: You can launch multiple backends with one launch statement. doc.powerdns.com/md/authoritative/settings/#launch PowerDNS will exhaust each backend for resources pertaining to the queries it gets in the order in which they are specified there.
    – ZaphodB
    May 30 '17 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.