0

We run 2 dedicated Windows 2008 R2 servers from our ISP. Yesterday for no reason at all 1 of our servers stopped sending email.

The server uses MailEnable for sending outgoing SMTP emails only. IE. There are no incoming email traffic at all. The emails are all being held in the outbound SMTP queue, and checking the debug logs for MailEnable I'm getting lots messages like this:

> SMTP Connection DNS Server could not resolve domain name (exampleDomain.com) in a timely fashion. Check DNS Server settings.

If I do an nslookup I get the following:

Default Server:  UnKnown
Address:  46.32.224.29

The IP 46.32.224.29 is one of our ISP DNS servers.

If I do ipconfig /all I see 2 DNS servers list, the one above and 79.170.40.187.

In DNS Manager if I try to add my server, or either of the DNS servers I just keep getting the message

The server is unavailable. Would you like to add it anyway?

I'm not sure where to go from here. We have not made any changes to our servers or DNS records. Our ISP wants to wash their hands of the whole situation, claiming, dedicated servers are the responsibility of the client.

I would appreciate any help at all with this problem.

Thanks in advance.

  • 1. You don't need to add those DNS servers to DNS Manager as they aren't your DNS servers, meaning they aren't under your control. 2. Try configuring your servers to use a different set of DNS servers, such as 8.8.8.8/8.8.4.4. – joeqwerty Apr 16 '17 at 15:52
  • Thanks for the suggestion. There has been a slight development. I found that the DNS service was not running. Managed to start it, after a little messing, and not in DNS Manager I can see my local server. I tried adding the servers you suggested, but still get the message The server is unavailable. I'm not sure what's going on. – Strontium_99 Apr 16 '17 at 16:01
  • I'm confused. Are you having a problem with the DNS server role or the DNS client? When I suggested using 8.8.8.8/8.8.4.4 what I meant was to use those as the DNS servers of the DNS client settings on the NIC of the server. Is the server running the DNS Server role? MailEnable uses the DNS server configured in the DNS client settings of the NIC. – joeqwerty Apr 16 '17 at 16:05
1

Check the port 53 TCP and UDP internal and external. And also check the Firewall on each machine.

If that is open. Check the Forwarders IP on each SERVER. if that is good and it's resolving to Gmail public DNS servers (8.8.8.8 and 8.8.4.4).

the other tests involve the use of telnet to check the ports 53 to be open. or use the DNS management to check recursive and statics DNS queries.

  • Problem solved. Not only had the DNS services disabled themselves, but the "Disable recursion (also disable forwarders)" had checked itself. Still got no idea how this happened because we haven't altered anything. All flowing smoothly now. Thanks for the advice. – Strontium_99 Apr 17 '17 at 10:32
  • You welcome :). Lot's of things disabled in there – Jose Ortega Apr 17 '17 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.