0

I have a Laravel web application for which I have added a app.yaml file, but I receive the following error whenever I try to deploy the app using gcloud app deploy:

Details: [
  [
    {
    [enter image description here][1]  "@type": "type.googleapis.com/google.rpc.ResourceInfo",
      "description": "The \"appengine.applications.create\" permission is required.",
      "resourceType": "gae.api"
    }
  ]
]

The image is shared here:

enter image description here

I have given myself admin permissions for the app engine, however, I still receive the same error.

1
  • 2
    Currently your account needs Project Owner permission role to create an application. For more information, please visit this public issue tracker. – Kamran Apr 22 '17 at 19:42
1

This is clearly an indication you might have missed to enable your APIs . You can have a look here https://cloud.google.com/python/django/flexible-environment

in the link it explains that you should enable the Google APIs as the first things and you might have missed this step.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.