I have set up a pfSense virtual machine with two networks adaptators :

  • WAN : that is connected to an other router to get internet access
  • LAN : that is connected to the LAN ( but that's not the point here )

On my pfSense I've got an internet access but when a client is behind the pfSense, I can contact the first hop ( ) , the second hop ( ) , the third ( second router interface) so the routing is done well on the virtual Machine but I can't reach the Internet on a client...

If someone see where is the problem , I'll be glad to ear his answer ! Thanks for reading and have a nice day :)

  • Could you share the routing tables you configured? Are you using DHCP to configure the client's network settings? If so could you share that configuration as well? Can you share the outputs from traceroute?
    – inaki
    Apr 19, 2017 at 8:16
  • traceroute stops to the first hop ( so this is definitively a routing problem
    – KaAzZ
    Apr 19, 2017 at 14:39
  • I agree it's a routing problem, hence my questions :) Without more information it's hard to say what configuration is missing. From what you stated in your question it looks like you can also reach second and third hop but that's not the case ?
    – inaki
    Apr 19, 2017 at 14:50
  • After the "reset factory settings" it worked ! Thanks for your reply
    – KaAzZ
    Apr 20, 2017 at 6:49

2 Answers 2


Have you correctly configured the default routes for each router? Does each router know who to ask about networks it does not know?

The default route of should be your internet provider's default gateway. The default route of and should be, and the default route of the clients on should be

It's difficult to know without knowing more about your configuration.

  • Thanks for your rapid answer Well on pfSense I can't tell him to use the (box card ) or even ( the pfSense card ) on the LAN card which is configured in /16 , I can now see what is missing but can't configure it... The route that says " all packets from to ( or any networks ) should use this gateway" is missing but generates an error on pfSense
    – KaAzZ
    Apr 19, 2017 at 14:26
  • Is there inverse route known to the internet router? Is that router aware of the underlying networks containing your hosts?
    – inaki
    Apr 19, 2017 at 14:51
  • Hi guys , I made a "factory reset" of the pfSense and it worked... Thank you all for your reply
    – KaAzZ
    Apr 20, 2017 at 6:47

I made a "factory reset" of the pfSense and it worked... Thank you all for your reply

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .