-1

Do someone have correct tcp vnc configuration for kvm? I have tried various ways correcting lines in libvirt.conf, qemu.conf, but they do not help (changing listen address, changing flags, changing ports). Vnc always reject to listen on tcp connection. Now I simply remember that initially I should have changed listen_addr for vnc, set listen_tcp = 1, listen_tls = 0.

  • What are you trying to do, precisely? – Michael Mol Apr 21 '17 at 12:39
0

The listen_addr, listen_tcp and listen_tls options you mention here are in libvirtd.conf and affect the libvirtd daemon, not QEMU.

By default VNC servers will listen on 127.0.0.1, but this can be changed in qemu.conf, with the 'vnc_listen' parameter.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.