2

I own a mac and I need to test a Windows Server 2016 environment with Docker on it. So I run Windows Server on a virtual machine.

I can successfully install Docker ToolBox on the virtual machine, but when I run the Docker Quickstart Terminal it says:

"This computer doesn't have VT-X/AMD-v enabled. Enabling it in the BIOS is mandatory."

From what I have read here and there this could be related to nested virtualisation not being enabled, but I'm not sure. And if this is the cause how do I enable it ?

I've tried both with VirtualBox and Parallels Desktop, but I have the same error for both. Also the production system will probably run on some other (cloud) virtualisation technology, so I need to really understand the requirements.

  • 1
    The requirement is for the VM to support VT-X passthrough - that's it - hopefully your cloud provider allows for this, so do, some don't. Meanwhile have you checked that your CPU supports this, again not all do. – Chopper3 Apr 20 '17 at 12:37
1

You need to enable the features on the in the VM settings in your virtualization software. For Parallels, it looks like this would cover it.

http://kb.parallels.com/en/116239

0

If you have an Intel core-i* Mac, it is extremely likely that VT is already enabled in the BIOS.

But you must ALSO enable VT support in the Windows virtual machine because the Docker Engine uses Windows Hyper-V (to run a very lightweight VM to run the containers).

For Parallels @Cory Knutson has given a pointer.

I use VMware Fusion 8 on a Core i7 mid-2012 MacBook Pro.

The virtual machine settings for each VM include Processors & Memory -> Advanced which has a check box [ ] Enable hypervisor applications in this virtual machine.

This is not selected by default!

Oracle Virtual Box has a similar setting for each VM.

You will have to check with your cloud provider if VT can be enabled in their VMs.

  • This made me curious so I enabled VT in a Windows 10 Pro VM running on VMware Fusion 8.5 on macOS Sierra 10.12.4 on my mid 2012 Core i7 MacBook Pro. I had to up the memory for the VM to 4096 MB and lower the memory that Docker wanted to use to 1792 MB but at that point docker started. I tested by running the super-small Alpine Linux image with no problems. – lcbrevard Apr 30 '17 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.