I only use my server to send out mail as I use Zoho for receiving email at my domain. I want to disable postfix from receiving any mail as spammers always try to send me mail or use me as a relay.

2 Answers 2


Just add a firewall rule blocking port 25.

You can also bind Postfix only to the loopback interface in your main.conf with

inet_interfaces = loopback-only


I would consider it good practice to do both, that way you don't end up being a spam source if for some reason, one of the two methods gets turned off.


Either block port 25 on your firewall or following this guide for a send-only postfix configuration: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-postfix-as-a-send-only-smtp-server-on-ubuntu-14-04

  • Please don't post link-only answers to prevent link-rot. Instead, add the most important points from the link to your answer.
    – Sven
    Commented Apr 23, 2017 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .