1

I have an IBM x3850 m2 server, with ibm serveraid mr10k raid card, wich is a lsi megaraid card.

My problme is, if I try to run linux, with 4.4 kernel I need to use iommu=soft kernel arg to make it work. Without this option I get this error:

Calgary: DMA error on CalIOC2 PHB 0x3

I also try pci=nomsi but with this option I get another error:

NMI watchdog: Bug: soft lockup - CPU#1 stuck for 22s! [udevd: 1381]

I can solv this error with this arg: acpi=off but with this the system won't see the raid card.

The problem with iommu=soft is the huge load (around 70 or more). With kernel 3.10 the card work without problem. I'm using proxmox 4.4 on the server and the 3.10 kernel won't work with this version. There is two way for me, downgrade the proxmox or solve the problem with megaraid_sas driver.

5
  • There is a third option, upgrade your hardware to something from this decade? – Chopper3 Apr 24 '17 at 10:16
  • Yes this is the third. But upgrading the hardware becouse a driver problem the last option for me. If i don't can solve the software problem i need to upgrade my hardware. – Bttd Apr 24 '17 at 10:21
  • Is that server still supported by IBM? They came out nearly a decade ago if I recall correctly. – Chopper3 Apr 24 '17 at 10:59
  • As we are talking about unsupported hardware anyway (non-production mashine I hope), I would suggest to crossflash the mr10k to LSI firmware, set it to IT mode, use plain mdadm for your RAID and be done ... – s1lv3r Apr 24 '17 at 11:12
  • I think this is end of life product. – Bttd Apr 24 '17 at 11:13
0

LSI SAS3082E-R SAS SATA Raid Controller

I am not sure if I understand the problem right, but if you are talking about how to install Linux (Ubuntu), then do this:

  • Buy the controller above
  • deactivate the built in controller and replace it With the new one
  • make array for your hdd
  • Boot Ubuntu Server 15.04.
  • in install menu press f6
  • AT the end of the Text add after quite--- write : intel_iommu=on intel=soft
  • install
  • Reboot
  • Login
  • install ubuntu Desktop using: sudo apt-get install ubuntu-desktop or KDE using sudo apt-get install kubuntu-desktop
  • Restart using sudo reboot

That's IT! Ubuntu seems not to like the original controller

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.