2

I did the following :

  • Made an Azure load balancer to an availability group of 2 VMs
  • Created an HTTP health probe to monitor the site going to /
  • Verified that the site would respond to http://10.0.0.7:80/

The site doesn't come up.

The firewall is fine. If I switch to a TCP probe on port 80then the site comes up.

1

Somehow I ended up with a space in the path name shown here. Removing it (or creating a file called EXPLETIVE.HTM in the root of the website) solved the issue.

enter image description here

This was verified in my IIS server logs

2017-04-25 00:08:13 10.0.0.7 GET /+ - 80 - 168.63.129.16 Load+Balancer+Agent - 404 0 0 0

The plus symbol represents the space.

9
  • 1
    Those spaces can kill! – CtrlDot Apr 25 '17 at 2:17
  • @CtrlDot I still don't understand why no hostname field for VMS - but I've had enough load balancing for one day! – Simon Apr 25 '17 at 2:21
  • You require hitting a particular host header for your http probes? – CtrlDot Apr 25 '17 at 2:22
  • I'm still trying to figure out exactly how I set everything up but I wanted to be able to disable certain sites from particular nodes for various reasons and if host header was recognized I could just stop that site and it would be removed automatically – Simon Apr 25 '17 at 2:33
  • Azure App Gateway might be a better fit. Azure LB is only a layer 4 device, so you won't be able to do that. – CtrlDot Apr 25 '17 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.