0

I have a problem that I can't seem to find a solution to. When I click on a user in a specific location, SQL Server Manager 2016 crashes to an error dialoge. This is a repeatable incident. I'm on Server 2012 R2.

To trigger the error: Connect to Server Object Explorer, log in with sa user. Open Databases, right click the "test" DB, select Properties. Select the Permissions page. In the field "users or roles", when I press the eligible user, which is called test_dbo, SQL crashes with an error message: "SSMS has stopped working". The user has been given proper rights (at least as fas as I know), and is DBOwner. It is possible view the user's rights every other place I have tried.

When the error dialoge shows, pressing "Show problem details" shows:


Problem signature: Problem Event Name: CLR20r3

Problem Signature 01: Ssms.exe Problem Signature 02: 2015.130.16106.4 Problem Signature 03: 58891f43 Problem Signature 04: mscorlib Problem Signature 05: 4.6.1087.0 Problem Signature 06: 583e5abb Problem Signature 07: 3526 Problem Signature 08: 21 Problem Signature 09: System.ArgumentOutOfRange OS Version: 6.3.9600.2.0.0.400.8 Locale ID: 1044 Additional Information 1: 36fe Additional Information 2: 36fe547341409026b0499dff2436b6e0 Additional Information 3: 044d Additional Information 4: 044dbaa475e5e7b5545c7fb67a640214

Read our privacy statement online: http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline: C:\Windows\system32\en-US\erofflps.txt


I have tried a limited amount of things to remedy this, but nothing has worked. This includes reinstalling .NET, which one site suggested.

Has anyone else experienced this?

| improve this question | | | | |
  • If the SQL server engine is not 2016, try connecting under another version of SSMS and check if all the data is present and consistent. Otherwise report a bug to Microsoft. System.ArgumentOutOfRange means some integer value is not in the expected range, for example, that user's ID is not registered elsewhere. – Vesper Apr 25 '17 at 13:39
  • I see no reason why the SQL engine would not be 2016, since this is a fairly new installation, with no prior SQL versions where installed. It was not upgraded, but rather had a straight 2016 installation. Anyhow, how do I check which engine is in use? – Roger M Apr 25 '17 at 13:54
0

I couldn't open SQL management studio at all after upgrade of OS from 2008 r2 to 2012 R2.Installed the latest version of net 4.8 & also got rid of UAC. No more problems. This also got rid of issue opening server manager.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.