I'm running Ubuntu 8.04 as a virtual machine using VMware Fusion 3.0 on Mac OS X 10.5.8. I want to be able to ssh into my VM from the Mac OS X host (so I can use MacFUSE and SSHFS to mount the VM's files on the Mac).

I had this working previously, but then I:

  • upgraded Fusion from 2.x to 3.0
  • rolled the VM back to a previous snapshot
  • upgraded the VMware Tools in the VM

I re-installed ssh in the VM using sudo apt-get install ssh.

I then tried ssh from my Mac, and after some time it timed out. So I tried pinging the VM from my Mac, and 0 packets were received. (I can ping the Mac from the VM with no problem.)

Any advice on how to troubleshoot this?

Update: I tried switching from NAT to Bridged (as suggested by Stephen Thompson) and got strange "Time to live exceeded" messages when I tried to ping the VM. I realized that was due to the VPN I'm using. I disconnected from the VPN and can now ping the VPN and ssh into it, regardless of whether I use NAT or Bridged.

  • All of your network configuration might be a good start.
    – womble
    Nov 14, 2009 at 6:32
  • 2
    womble, I don't understand what you mean. Nov 14, 2009 at 14:41

3 Answers 3


Try setting your network to bridged, so it picks up a network address from your lan, and you will be able to gain access to it.


Silly question but is the current IP of the Ubuntu VM? For testing you should probably drop the firewall (iptables -F) if you configured it, as well.

  • Yes, I've of course double-checked that I have the right IP. (Using ifconfig. Because I'm using NAT in VMware Fusion to share the Mac's network connection, the IP number hasn't changed from when it was working before.) I didn't configure a firewall, but I ran iptables -F just in case. I still can't ping the VM. Nov 14, 2009 at 14:43

Steven Thompson's idea worked for me - for whatever reason adding an eth1 (bridged) seemed to fix eth0 (NAT) once I ran sudo dhclient (I checked, rebooting didn't fix it by itself, it was only fixed after I ran sudo dhclient )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .