1

To run SQL Server Engine under a domain account (that is not a local admin) requires multiple permissions, including "Permission to read the Remote Procedure Call service"

From internet searches we have gathered for subinacl QSETIL is desired for read but we also tried just L alone. Trying to grant perms from a command prompt as administrator with and without "" around service name.

subinacl.exe /service "RpcSs" /grant=mydomain\myuser=QSETIL

Gives error: RpcSs - OpenService Error : 5 Access is denied

Just trying to display permissions using below gives the same error

subinacl.exe /service "RpcSs" /display

Both commands work fine for service EventLog so it is something to do with permissions for RpcSs the remote procedure call service.

We have tried granting full permission to local administrators as well as system to the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs

We still get the error on both Windows 10 and Server 2016. Nothing thrown to Security, System or App event log.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.