1

I'm following this tutorial https://gooroo.io/GoorooTHINK/Article/16420/Lets-Encrypt-Azure-Web-Apps-the-Free-and-Easy-Way/20047 . I created the principal, configured all the Web App Settings variables described (I even configured the email address and the domain name as an extra, since I don't see the GUI anywhere). The extension seems to install without an error. I restarted the web app, and I even see the running WebJob by the extension.

I cannot figure out where to get to the configuration interface of the extension though. The tutorial above says

After the restart, click the triangle Launch button that replaced the extension's install button."

The extension installation UI seemingly changed since the article. I don't see any triangle. There's a browse button, but that's disabled.

The github wiki doesn't mention anything either, like it was straight forward: https://github.com/sjkp/letsencrypt-siteextension/wiki/How-to-install#configure-the-site-extension

The first page of the site contains the following...

What site? I tried to navigate to /letsencrypt/ of my webapp but it doesn't exist.

I'm not presented with any dialog when I install the extension.

enter image description here

enter image description here

If I look at the installed site extensions from the Kudu SCM site, under the installed section I see the two installed extension properly, but oddly I can install them again, and I suspect that the "+" button should turn to a triangle (as the original tutorial suggests)? If I install it again supposedly it installs itself successfully again, but I still don't know where to finish the GUI part of the config.

In the WebApp Settings I didn't specify letsencrypt:ServicePlanResourceGroupName because I don't know hwta it is and we have only one service plan.

enter image description here

3

The UI is at https://[your-webapp].scm.azurewebsites.net/letsencrypt

If it doesn't exists try to restart the SCM site. I should exits. Otherwise provide the logs from D:\home\LogFiles\Transform

  • I thought I tried that URL before. I see the website now. Battling with the right TenantID. – Csaba Toth Apr 30 '17 at 17:48
  • I was having exactly the same problem – MrBliz May 6 '17 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.