0

I have a user that has shell:

/etc/passwd/ :   /var/lib/myuser:/bin/bash

The permit password of /ect/ssh/sshd_config has been set to yes I can do sudo su myuser on the machine and it does not need a password. But when I ssh tot he server using myuser, it asks for password and an empty password does not work?

Can some one please explain, why it cannot ssh?

4

The SSH daemon by default will not allow connections from users with no passwords. This is in place for a very good reason, and I highly recommend using SSH keys if you want to connect without typing a password. If you really want a passwordless connection, you will need to edit /etc/ssh/sshd_config and set the following:

PermitEmptyPasswords yes

Once you have updated that flag and restarted the service you should be able to connect without a password. Again, please do not do this for any machine that has public internet access - your server will be compromised.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.