1

I've set up a new VM via VMWare and it runs CentOS7. Typically, when I run hostname -i, I get the IP address of the server I'm on. However, on this new VM, I get (these values are slightly altered):

hostname -i
fe09:204g:s3t0:s30f:O0ef%ens192 10.22.22.32

I recognize the 192... but why is this MAC address-like value showing up? I'm trying ssh to this new machine and in troubleshooting, I ran across this and wanted to understand before I proceed.

5

That MAC address looking value is an IPV6 address. If you have IPV6 enabled and routable on your ESXi host/guest, then the -i option will display all routable ip addresses.

If you use --all-ip-addresses or -I, this will omit loop-back and IPV6 link-local addresses. It should just display any IPV4 addresses.

2

You're seeing an IPv6 address there. The value after the % is the adapter that the IP address belongs to (in this case, ens192)

Although, one does wonder why your IPv6 address has non-hex characters in it. Does the output of ip a also show that IP address?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.