Strange issue started yesterday: I cannot ping any Windows PC on my local network.

I have (2) Windows 7 Pro devices, one of which was reimaged just before this issue started; (1) Windows 10 Education device; (1) Linux Mint 17.3 device; and an Android 7.0 device. No matter where I initiate a ping from, including my gateway, I cannot hit any of my Windows devices. I can hit my Linux and Android devices fine from any of the others though, including the Windows ones.

I have tried turning off A/V and Firewalls; rebooting all devices involved, including the router; flushing DNS from the Windows PC's; I have looked for rules in the router and on the devices that might be blocking ICMP; and I have found nothing.

Unfortunately, I rebooted the router before pulling logs from it... so those are gone. I have not made any changes to these devices (other than a clean image on one of the Windows 7 PC's), nor have I made changes to my router.

Everything worked fine until yesterday evening. I RDP'd into the freshly imaged PC to start reinstalling software and configuring the OS, etc. AVG on that device froze while I was configuring it and I had to hard boot the PC. When it came back up I was unable to RDP it again or ping it. Today I realized that I couldn't ping any of the Windows PC on my network. Also, strange: I use xrdp on the Linux box and I can connect but not login to the box. SSH on that box works just fine though (I even tried to tunnel RDP through SSH and still no go). All of these devices connect to the internet just fine. They can ping any non-Windows device on the network.

Any suggestions or guidance would be greatly appreciated. Thanks in advance!

Update: I connected my work laptop that has not been on my network since the issue first arose. It did not respond to a ping, nor did it receive a response from any other Windows devices, but it could ping my Linux box. So, I performed a factory reset on my router... did not make a difference.

  • Do you use Windows domain controller? May 5, 2017 at 5:18
  • @Mikhail No, this is a home network.
    – redbiscuit
    May 5, 2017 at 13:11

2 Answers 2


Windows 10 doesn't return a ping by default. I'm guessing Windows 7 doesn't either. Have you ever pinged one of the Windows machines successfully before?

  • Marking this as the answer, because it filled in the gap I was missing. I had been able to ping between all my Win7 PC's before, but had never tried Win10. I did not know that Win10 block ICMP by default. I had been focusing on the router as the issue, but it turns out it was my AVG firewall on the Win7 PC's. They received an update that marked my LAN as a public network and was blocking remote connections and inbound ICMP. Not sure why the firewall continued blocking even when I disabled AVG, but adjusting the policies on these PC has fixed my issue.
    – redbiscuit
    May 7, 2017 at 2:32

Can we assume that these Windows PCs are not VMs (and thus cannot have the same MAC addresses for the network interfaces)? Do you get the same behaviour (e.g. no ping, no RDP) if you disconnect all but one of your Windows PCs? If you ping a Windows PC from the Linux PC, does it manage to get its MAC address? To test this, test with ping and arp (you might need to install net-tools for arp)

arp -d <windows_pc_ipaddr>; ping -n 1 <windows_pc_ipaddr>; arp -n <windows_pc_ipaddr>

If you get a MAC address, the problems lies at the IP level, indicating that some firewall or switch is blocking access. To check that the Windows PCs don't have the same MAC address, repeat for the other Windows PCs and check the MAC addresses.

  • Correct, these are physical devices, not VM's. Followed your suggestion and removed all other Windows PC's from the network. The Linux box is able to get the MAC from one of the devices after deleting it from the ARP table. My initial thought was that the router was blocking ICMP, but I didn't make any changes to the router prior this issue and the factory reset didn't make a difference.
    – redbiscuit
    May 7, 2017 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.