6

The windows 10 desktop client for remote desktop can save my password for the remote client ( a windows 10 VM ). This is all good. Just click to open a session. However after a 5 minute timeout the remote desktop locks the screen and asks for the password. I then disconnect the RDP session and click on the saved RDP session and I am back in. No password needed but this is annoying.

I have tried changing the timeout on the remote windows 10 system but I seem to be locked out of doing that.

enter image description here

Notice that the option to change the timeout is greyed out. Is there a way to ungrey this option or is there another way to achieve this?

(I originally found this but as you see above it doesn't work )

1

2 Answers 2

3

As described in the article Disable Remote Desktop Auto Lock Screen on Idle you have already found:

If the “On Resume, display logon screen” checkbox is disabled or grayed out like what is shown at the screenshot below, it means that there is a group policy being implemented probably by your company’s network administrator to prevent the local logged in user from changing this setting.

After that the article is bullshit; you should not fight with Group Policy by using some local registry tweaks!

The Screen Saver Group Policy Settings are in:

User Configuration\Administrative Templates\Control Panel\Display

Currently Password protect the screen saver is enabled. Change to disabled to get directly what you want or not configured for letting your users deside.

(If you can't change the GPO, your question becomes off-topic on Serverfault.)

1

The easiest way I've found to deal with this is to run a mouse mover/jiggler program that periodically moves the mouse a few pixels every minute or so in order to simulate mouse activity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.