0

My account is a domain admin, I often log onto a particular server in our network (not the DC), and until recently I could query AD with PS commands, e.g.

Get-ADUser crm.webserver -Properties *

and I would see the PS message,

'Creating a new session for implicit remoting of "Get-ADUser" command...',  

followed by the results I wanted to see, in this case the properties of the user. But recently the same PS message has not been followed by the results I wanted, but instead I see,

'Insufficient winsock resources available to complete socket connection initiation.  
    + CategoryInfo: NotSpecified: (crm.webserver:ADUser) [Get-ADUser], ADException  
    + FullyQualifiedErrorId: ActiveDirectoryServer:0,Microsoft.ActiveDirectory.Management.Commands.GetADUser  
    + PSComputerName: dc01.wxyz.dom'  

Can anyone tell me what likely has gone wrong and point me in the right direction to fix it?

migrated from stackoverflow.com May 13 '17 at 18:07

This question came from our site for professional and enthusiast programmers.

  • This is going to be better asked on ServerFault. This error message means you can't open up a socket to connect because they are all in use. This is going to be an Operating System issue rather than a PowerShell code issue. Something has gone wrong on your server, something is likely repeatedly opening connections and not closing them. – BenH May 10 '17 at 15:09
  • Can I or someone move the question to ServerFault or do I just re-ask it? – colinp_1 May 11 '17 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.