3

When I use robocopy with /copyall flag, the 1st attempt for the files will be display as "New Files" and the output will display the number of new files copied and other transfer/bytes information.

The 2nd attempt for using the same path + command will display "Modified" for the same files even though there are absolutely NO changes or any modifications at all/the output will still display "x files copied and bytes etc info"

The 3rd and subsequent attempt will then behave normally (output will not show any new/modified files transferred)

See output below

PS C:\Users\administrator.SG-EQUINIX> robocopy B:\MSSQL\Test\test1 \\sqldr1\Backup\Test /copyall

-------------------------------------------------------------------------------
   ROBOCOPY     ::     Robust File Copy for Windows
-------------------------------------------------------------------------------

  Started : Monday, 15 May 2017 12:37:33 AM
   Source : B:\MSSQL\Test\test1\
     Dest : \\sqldr1\Backup\Test\

    Files : *.*

  Options : *.* /COPYALL /R:1000000 /W:30

------------------------------------------------------------------------------

                           2    B:\MSSQL\Test\test1\
100%        **New File**              34.8 m        IBXX_backup_2017_04_19_173001_8474121 - Copy.trn
100%        **New File**              34.8 m        nn.trn

------------------------------------------------------------------------------

               Total    Copied   Skipped  Mismatch    FAILED    Extras
    Dirs :         1         0         0         0         0         0
   Files :         2         2         0         0         0         0
   Bytes :   69.65 m   69.65 m         0         0         0         0
   Times :   0:00:15   0:00:15                       0:00:00   0:00:00


   Speed :             4723113 Bytes/sec.
   Speed :             270.258 MegaBytes/min.
   Ended : Monday, 15 May 2017 12:37:49 AM

PS C:\Users\administrator.SG-EQUINIX> robocopy B:\MSSQL\Test\test1 \\sqldr1\Backup\Test /copyall

-------------------------------------------------------------------------------
   ROBOCOPY     ::     Robust File Copy for Windows
-------------------------------------------------------------------------------

  Started : Monday, 15 May 2017 12:38:11 AM
   Source : B:\MSSQL\Test\test1\
     Dest : \\sqldr1\Backup\Test\

    Files : *.*

  Options : *.* /COPYALL /R:1000000 /W:30

------------------------------------------------------------------------------

                           2    B:\MSSQL\Test\test1\
            **Modified**              34.8 m        IBXX_backup_2017_04_19_173001_8474121 - Copy.trn
            **Modified**              34.8 m        nn.trn

------------------------------------------------------------------------------

               Total    Copied   Skipped  Mismatch    FAILED    Extras
    Dirs :         1         0         0         0         0         0
   Files :         2         2         0         0         0         0
   Bytes :   69.65 m   69.65 m         0         0         0         0
   Times :   0:00:00   0:00:00                       0:00:00   0:00:00


   Speed :           2282592000 Bytes/sec.
   Speed :           130610.961 MegaBytes/min.
   Ended : Monday, 15 May 2017 12:38:11 AM

Anyone has any idea why ?

============== Added below to reply to comments ===============

Both SRC and DEST have the same filesystem (NTFS) , sector and segment size.

I have also using the powershell command getItem-Property on the source file and destination file after it is being robocopied over.

Their creation,access,write time are absolutely the same. Yet..the 2nd attempt of the same robocopy command still show the same file being copied over as "Modified" although there is actually no actual copying over (the "Time" reflected as 0).

Tried the /FFT flag, same behaviour, 2nd attempt still show files as Modified. When there is no change at all to the creation,access,write time of the same file on both sides.

My braincells are dying..

  • I can't repro. There must be something in your environment that's involved. – Twisty Impersonator May 19 '17 at 0:59
  • You're using a B: drive - is that a USB that's formatted as FAT? – Christopher_G_Lewis May 19 '17 at 1:36
  • Noob - Look over here: superuser.com/questions/1026184/…... you may just need to use the /FFT switch which is probably where Chris was going with that comment next. – Pimp Juice IT May 20 '17 at 5:48
  • to all - I added comment to the original post, please take a look – Noob May 20 '17 at 6:39
  • Have you tried using the /m switch? – SturdyErde May 22 '17 at 15:00
0

I seem to get the "modified" to show in a robocopy of matching files at source/destination across time zones. see some of the robocopy definitions below.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.