1

UPDATE: I have ordered a 8TB drive to be delivered tomorrow. My working theory is while Windows Server let me backup to the FreeNAS CIFS share, that on restoration Windows is being finicky about the CIFS and wants NTFS. I'll check that theory by formatting the 8TB drive when it arrives to NFTS and then copying the over 6TB system image from FreeNAS onto it. Plug it the drive direct into the server and attempt the restore again. Still looking for any other thoughts or confirmations.

ORIGINAL POST I have a complete system image of my Windows Server 2012 system. This image is on my FreeNAS server.

I updated my RAID 5 on my Windows Server with larger disks from a 4 x 4TB to 4 x 8TB and got caught flat with the whole over 16TB limit due to drives being made with 4K clusters and needing to be 64K clusters to expand beyond 16TB. So I made sure my backup images were good and started to restore the system image, which would then reformat the volume at the larger cluster size.

Booted up the Windows 2012 disk into repair mode and set it to restore the image. No problems getting it to see the path to the FreeNAS server. No problems with it finding the backup image.

I start the re-image and the system says it is preparing and then about 30 seconds in it says:

Restoring Disk (EFI System Partition)

Then I get the below error:

The system image restore failed.
Error details: Incorrect function. (0x80070001)

I've looked up this error code and can't really find anything relevant to my issue.

And, of course, the system image ran just enough to so that I can't reboot my server.

I don't want to mess with anything further until I get some advice. I'm stuck with what to do here.

Any help/advice/idesa are appreciated!

1

It is good you are taking a breather. And you came to the right place for advice.

When you are ready, it is time to put on your detective hat and work the case methodically.

First off, your first data point is that you have verified that you have a good image backup.

Second, you have one clue that might be relevant: The cluster size difference.

I presume you still have the original 4 drives from your former RAID5, so reinstall those drives and go back to your original configuration.

If you have trouble rebuilding the original RAID setup, do the best you can even if it means starting with it blank.

If it works, that is great but it does not validate your restore program.

If you have to restore the image into that new (older) configuration, do so.

When that works then you have a second clue: possibly the total size difference.

And you also have one more data point: You have now validated the restore program.

--> Then breathe a sigh of relief. Take a walk and Praise the Lord that He created the idea of making backups, and pat yourself on the back for doing it.


Then at that point you have restored service which will buy you time to investigate the FreeNAS restore error.

I would be surprised if the cluster size is the issue, but from what you've written it is a distinct possibility.

Yet it may not be the culprit. It may simply be that the restore program is having trouble with the overall size of the target RAID set.

So then, work the case using the clues you have.

Google is your friend. Certainly you can't be the first to have had this problem.

FYI: I have had to solve issues just like this, but in the pre-Google days. You are very fortunate to have this issue in 2017 instead of 1997. ;-)

Good luck in your investigation.

Any more information on this issue can be put into comments below either your question or this answer.

| improve this answer | |
  • Original 4 drives used to make the FreeNAS system once the server had come up with the new 4x 8TB raid and I had a good backup. – BitBug May 15 '17 at 23:16
  • Cluster size should not be the issue. New 4x8TB RAID is still at 4K cluster and thus so is the backup. The 64K Clusters won't kick in until the new RAID is formatted, which would be part of the restore of the server image. No restore, no 64K clusters. – BitBug May 15 '17 at 23:19
  • Good news. Will you please upvote me for laying out a process for you? ----> I wanted to tell you something: I looked up that error code and found out it is a Windows error code. There are people who say they were stuck at it and fixed it. Have a look at this search: google.com/search?q=Incorrect+function.+(0x80070001 – SDsolar May 16 '17 at 4:03
  • I still think total size may be the problem, so keep following the procedure. Go back to the original drives and rebuild the RAID as it was, then restore your image, just to verify the restore procedure with the original size. Then once it is back up and working you will have time to do the research to find out if this has happened to other users of your restore program. You can worry about the NAS after you get your server working again. – SDsolar May 16 '17 at 5:45
1

I just ran into this problem in 2019 while trying to restore Windows 2012 Server. The problem is that Windows Backup restore in the baremetal environment just has a problem with Samba (4.7.6). If you copy the WindowsImageBackup directory to a windows machine and share it. It will work. There is nothing wrong with your backup.

| improve this answer | |
1

I can confirm that there is definitely something to the theory about the error being caused by trying to recover using an image stored on a NAS device. I've tried many different things to do a bare metal recovery from one server to the other. These are different server types with different RAID controllers. The old one being a software RAID controller and the new a hardware RAID controller. I was suspecting that the error was caused by some of those differences, but as soon as I moved the backup from our Netgear ReadyNAS to a Windows server and started the recovery, this error was gone. Thanks for the tip; I have been looking all over the place for the cause of this cryptic error!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.