3

Summary: Receiving mail to username@foo.com works, but user.name@foo.com doesn't.

On an IBM Domino 9.0.1, a proper Global Domain document exists for the domain foo.com

Global Domain doc

One user has two email addresses: username@foo.com and user.name@foo.com

This user can successfully receive email at the first address but not the second. The error generated by the server is:

SMTP Server [2C5C:000A-3544] Attempt to relay mail to user.name@foo.com rejected for policy reasons. Relays to recipient's domain denied in your configuration.

I have added the setting SMTP_LEFT_DOT_NEVER_DOMAIN=1 to the server, but the behaviour didn't change.

I also tested with SMTP_REPLACE_DOTS_OFF=1, without luck.

The part after the dot is not similar to the domino domain name. It's not similar to anything.

Here's how the Person's document looks like: user name's Person's document

I'm running out of things to try. Do you have a solution or a recommendation?

Thanks

  • How does your configuration document for that server look like? Please set the logging in that document for Mailrouting to verbose, so that you can see, what it really tries to do. I think, that "name" (in user.name) might really have something to do with your DOMAIN- Name or any Foreign- Domain that is configured. Then SMTP_LEFT_DOT_NEVER_DOMAIN=1 should help, but lets see... – Torsten Link May 15 '17 at 6:41
  • I've enabled logging for the SMTP server (since that this problem is with incoming mail), and in the most verbose output, nothing helpful was showing. Just the casual message: SMTP Server [1474:0005-2E2C] Attempt to relay mail to resu.eman@foo.com rejected for policy reasons. Relays to recipient's domain denied in your configuration. after the RCPT TO command. I've changed the user name again, just to be sure it's not conflicting with anything. – Sam Sirry May 16 '17 at 4:07
  • In the server configuration, I had the domino domain name in the field Allow messages to be sent only to the following external internet domains: %DOMAIN. Removing this value solved the problem, but effectively made the server an open relay despite having anti-relay enforcement set for all connecting hosts. – Sam Sirry May 16 '17 at 4:13
  • It seems that SMTP_LEFT_DOT_NEVER_DOMAIN is having no effect here. – Sam Sirry May 16 '17 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.