0

I'm struggling with update deployment from WSUS server (2012 R2) to our client computers and can't find solution on Google so I'm here. For the first time.

The problem occurs only on some hosts and not always. Currently I'm trying to fix this while using a laptop with fresh installation of Windows 10 1703 as a test client.

What happens: When I click search for updates button on Windows client, it finds 31 items (MS Office, Silverlight - selected on wsus) but doesn't progress with download - it's stuck at 0 percent.

Here is what i get from "ReportingEvents.log" file on client machine:

DllHost.exe Success Software Synchronization    Windows Update Client successfully detected 31 updates.
DllHost.exe Success Pre-Deployment Check    Reporting client status.
TrustedInstaller FOD    Success Software Synchronization    Windows Update Client successfully detected 0 updates.

So first it finds updates but then "naaah, there are no updates, brah"

Any clues?

Thank you in advance.

EDIT: So i uninstalled all the updates from client machine and searched for them once again. Windows found uninstalled packages, downloaded them but got stuck at 27% when these Office updates started to download.

  • Have you tried "wuauclt /resetauthorization" on the client? Have you tried deleting the softwareDistribution folder on the client? Have you tried seeing if the client can download the wsus cab file from a browser to make sure it's connection is working? – Jon May 18 '17 at 19:50
  • Yep tried that with no effect - cab files were downloading. Fortunately I found the solution. – Frosty May 22 '17 at 7:00
0

Ok, I think I finally fixed it.

  • I ran Adamj Clean-WSUS script (when you use WID you have to install "Microsoft® ODBC Driver 11 for SQL Server" first),
  • I moved "WsusContent" to a bigger storage (even though I had about 80GB of free storage left), without transfering the data (wsusutil.exe movecontent path -skipcopy).

Now everything seems to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.