40

Is it possible to reset the password on a SuperMicro IPMI interface? My motherboard is model X8STI-F.

3
  • I've done it on a HP DL585 system, and manipulated IPMI values on Sun X2200-M2 and V20z computers, so there's probably a way. I'd poke around on the Supermicro site. Commented Nov 16, 2009 at 4:14
  • what about same procedure for JBOD? You can't connect with ipmicfg or tool. Need to target the IP address and authenticate before you can change anything. Is there a battery to pull or a jumper to reset that actually resets the creds back to default? Thanks.
    – Kevin
    Commented Aug 2, 2016 at 20:52
  • @Kevin the method to do this varies by manufacturer and management interface. This is for Supermicro motherboards. Clearing the main system BIOS may or may not clear a BMC BIOS depending on the type of system. In Server systems you generally don't want to nuke the System bios because that can affect complex boot order or processor timing configurations which may not be the manufacturer defaults for specific needs of hardware within the system or because it was changed to support functions for a VAR. Commented Jun 30, 2021 at 15:06

9 Answers 9

31

If you access it locally you can specify a new password. On Linux this would be done via ipmitool. Something like this should work:

ipmitool -I open lan set 1 password NEWPASSWORD

If you don't know which channel is your ethernet interface, just page through them one at at time, like so:

# ipmitool -I open channel info 1
Channel 0x1 info:
  Channel Medium Type   : 802.3 LAN
  Channel Protocol Type : IPMB-1.0
  Session Support       : multi-session
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
  Volatile(active) Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : enabled
    Access Mode         : always available
  Non-Volatile Settings
    Alerting            : disabled
    Per-message Auth    : disabled
    User Level Auth     : enabled
    Access Mode         : always available

Note that the medium type is "802.3 LAN". That's the one you want. Other channels may look like this:

# ipmitool -I open channel info 2
Channel 0x2 info:
  Channel Medium Type   : Serial/Modem
  Channel Protocol Type : IPMB-1.0
  Session Support       : single-session
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
# ipmitool -I open channel info 3
Channel 0x3 info:
  Channel Medium Type   : System Interface
  Channel Protocol Type : KCS
  Session Support       : session-less
  Active Session Count  : 0
  Protocol Vendor ID    : 7154
9
  • When you refer to linux os, you mean that i should connect to the server locally with a laptop under linux and then issue those commands? Also, do i need to connect directly to the ipmi interface right?
    – madpato
    Commented Nov 17, 2009 at 13:53
  • When I mentioned Linux, it was because you didn't specify the OS in your post and that's the only one I know. If you're using Windows, it wouldn't work to just connect with a Linux laptop, but you should be able to boot off a Linux live CD (e.g., Knoppix) and use the ipmitool command there. It would probably be easier to find a native utility for Windows. It looks like ipmiutil is available for Windows. It looks like ipmiutil is available. Also check this out serverfault.com/questions/1395/how-to-utilize-ipmi-on-windows
    – Insyte
    Commented Nov 17, 2009 at 17:29
  • well i forgot to mention that it is a linux os, debian lenny 64. so i could do it remotely (i dont wanna go to my dc) The system is running fine, i'm just worried if i ever need it i will not have the password to access it.
    – madpato
    Commented Nov 23, 2009 at 16:34
  • 1
    Then what I described should work: Log in remotely via ssh and set the IPMI password. When I said "locally" I meant that you would be running ipmitool while logged into the server, not on another host.
    – Insyte
    Commented Nov 23, 2009 at 20:25
  • 4
    You'll need to load the modules: modprobe ipmi_si; modprobe ipmi_devintf; modprobe ipmi_msghandler
    – Insyte
    Commented Nov 24, 2009 at 23:02
28

I just had to deal with this same issue yesterday, I was not able to log into my SuperMicro IPMI web interface because I had not used it frequently and forgot the password. The command in Insyte's answer did not work for me but it was close. This command worked to reset the ADMIN account's password:

ipmitool -I open user set password 2 ADMIN

The number 2 there is the user id. The ADMIN account defaults to user id 2. So I'm setting user id 2's password to ADMIN which is the default, but you could put any other password there.

Thank you to Insyte for pointing me on the right track of using ipmitool, after a few searches online I was able to find this working command. Hopefully it will help someone else that stumbles on this question.

2
  • 1
    Thanks, this worked for an X8DTU. I needed to 'yum install OpenIPMI' and then 'service ipmi start' which loads the modules for you. EL6 in this case. Commented Aug 20, 2015 at 17:31
  • 1
    This worked for me too (while Insyte's answer did not). Remember to run this command as root. Thanks @ben-baron
    – sajjadG
    Commented Jul 5, 2019 at 10:53
19

Supermicro IPMI BMCs can be fairly erratic and troublesome. You should always use the utilities and tools provided by Supermicro before attempting a fix with universal tools such as IPMITool.

It is not necessary to reset the entire unit as others have suggested.

If you have physical access to the server, follow these simple steps to reset the ADMIN password on your IPMI:

  1. Create a bootable DOS USB stick using Rufus.
  2. Download the latest IPMICFG utility released by Supermicro.
  3. Extract the archive and copy the contents of the 'DOS' folder on to your bootable DOS USB.
  4. Boot your server into DOS and navigate to the 'DOS' folder you copied on to the USB.
  5. Get the user ID of the IPMI user whose password you want to set:

    ipmicfg -user list

  6. Set a new password for that user (the ADMIN user typically has an ID of 2):

    ipmicfg -user setpwd 2 your_password_here

  7. Login to the IPMI web GUI using the password you just set.

I've reset the ADMIN password on dozens of Supermicro IPMI BMCs. Of all the methods I've tried, this is the only procedure that works 100% of the time.

Note: If you already have Windows or Linux installed on your system, then you can skip steps 1, 3 and 4 and merely execute the commands in steps 5 and 6 using the appropriate executable from the Supermicro toolkit downloaded in step 2. If you are using Linux and you encounter kcs_error_exit messages when invoking ipmicfg commands, then you need to install the OpenIPMI library and enable the ipmi_devintf kernel module.

The following commands work on CentOS 6:

yum -y install OpenIPMI
modprobe ipmi_devintf

Remember that the command modprobe ipmi_devintf will need to be re-run every time you reboot the server.

2
  • 1
    You may also use IPMICFG recorder on USB flash directly from UEFI Shell (F11 while boot) without other OS. It was much simpler and faster rather creating bootable stick. Still above pt. 5 and 6 works like a charm! Commented Dec 19, 2019 at 23:04
  • 1
    For some reason the ftp server did not work. I found ipmicfg here: supermicro.com/SwDownload/SwSelect_Free.aspx?cat=IPMI
    – krdx
    Commented Aug 28, 2021 at 18:57
9

Best way is to reset to defaults and clear FRU&LAN with SuperMicro native tool, like so:

./ipmicfg-linux.x86_64 -fde

(All this may take a few seconds to take effect, so wait between commands!)

Now turn off the DHCP setting restored from factory defaults with

./ipmicfg-linux.x86_64 -dhcp off

then, restore your network settings with:

./ipmicfg-linux.x86_64 -m $IP_ADDRESS
./ipmicfg-linux.x86_64 -k $NETMASK
./ipmicfg-linux.x86_64 -g $GATEWAY_IP

I've noticed, that sometimes, you need to reset BMC unit for it to take effect. Just today, was unable to ping my server's IPMI IP address set via ipmicfg utility until after BMC reset:

./ipmicfg-linux.x86_64 -r

You'll have to configure the IP/Netmask/Gateway again with the same tool, but this is the only way I could make it work.
OpenIPMI and IPMITools did not work for me on Debian Squeeze. I've tried resetting the password, cold resetting BMC, to no avail. However, they are good for setting IP and reading sensor data.

You can get the appropriate version for your OS from SuperMicro FTP:
ftp://ftp.supermicro.com/utility/IPMICFG/

2
  • 1
    Be sure to write down the network information first. People who do this are likely in a datacenter without a pad of paper. Commented Sep 6, 2012 at 23:26
  • 2
    this definitely works! We couldn't get subsequent commands to work because it reverts to DHCP, so we connected via DHCP and got the IP, then were able to reconfigure. I updated your answer to reflect turning DHCP off first. Commented Oct 22, 2012 at 23:52
3

If you rarely use the IPMI interface it's possible it's still using the default username/password ADMIN/ADMIN (case sensitive).

2
  • i tried with ADMIN/ADMIN but found out that itis admin/admin ie small letters , anyway thans for the hint
    – user126897
    Commented Jul 3, 2012 at 2:44
  • I should add an update here: Any of 9th gen or newer motherboards no longer ship with the ADMIN/ADMIN default (due to a California law about default maintenance passwords). Their default password can be located in two locations: 1) The pull out 'toe-tag' if the motherboard and chassis were shipped as a system from Supermicro. 2) A sticker on the motherboard directly either near the SMC port or near the Motherboard Serial number sticker. It is in all CAPS with a barcode and usually says BMCPWD: Commented Jun 30, 2021 at 14:55
1

This simple answer is different than then others which need some other formal OS installed to reset the password.

Boot a thumb drive with the proper IPMI firmware file and the proper flashing utility for your motherboard from SuperMicro's website. We use a dos based one for simplicity. If you already have the current IPMI firmware Simply flash it with the same version you already have.

Most of our systems are X8 based boards that have onboard IPMI. These use YAFUKcs (Yet Another Firmware Updater).

If you normally save the config while updating, simply leave off the -c option yafukcs -full romfile.ima instead of yafukcs -full -c romfile.ima

Interestingly enough, leaving off the -c option does not cause IPMI static addressing to be reset in the BIOS. It only affects settings within the IPMI environment, such as LDAP, NTP and any alert notifications you have configured.

You should consider flashing the system BIOS after the IPMI update, however it isn't required. If you flash the system BIOS, those settings will be reset, but the IPMI LAN settings will not change.

1

Hate to dig up "old threads" but this one still comes up first when looking for a solution to the listed problem.

I've just found that the IPMIView tool from the Supermicro website can change the ADMIN password on the IPMI admin account! :)

1
  • The ipmiview tool can only change the password after you authenticate with the existing password. All of the other answers and the question are about what to do without the password. Commented Mar 27, 2020 at 23:55
1

The suggested solutions did not work for me on my SuperMicro X11SCL-F running Ubuntu 18.04. Here is how I was able to successfully reset the ADMIN password:

ipmitool user set password 2

It then prompts you to enter the new password. Hope this helps somebody out there. After that, just use the web interface to login with ADMIN / #NEWPASS#

0

I have some additional information to add following other answers that helped me along my way.

In my case, I have a Supermicro X10SLM-F (from around 2014 or so) which I had purchased from someone who forgot to reset the IPMI settings on one of the boards I had purchased from them.

These steps were performed on ipmitool version 1.8.19 on Debian 12. The Debian package version used is 1.8.19-4. I know about the 'IANA PEN registry' error, but ignored it at the time as I was using a temporary installation left over on a spare SSD from a different task. The mainboard used on has IPMI ROM version 01.35 dated 14/3/2014 and BIOS version 3.0a dated 21/12/2015 (d/m/y). The tool has to be run as the root user, but I decided to just use sudo instead.

In my case, it appeared that user ID 1 wasn't used.

kevin@temporary:~$ sudo ipmitool -I open user set password 1 ADMIN
IANA PEN registry open failed: No such file or directory
Received a response with unexpected ID 0 vs. 1
IPMI command failed: Invalid data field in request
Set User Password command failed (user 1)

With that, I tried just creating a separate IPMI user, which failed due to a typo ('username' when it should just be 'name') but did trigger a help prompt showing me that I can still just list the users.

kevin@temporary:~$ sudo ipmitool -I open user set username 2 kevin
IANA PEN registry open failed: No such file or directory
User Commands:
               summary      [<channel number>]
               list         [<channel number>]
               set name     <user id> <username>
               set password <user id> [<password> [<16|20>]]
               disable      <user id>
               enable       <user id>
               priv         <user id> <privilege level> [<channel number>]
                     Privilege levels:
                      * 0x1 - Callback
                      * 0x2 - User
                      * 0x3 - Operator
                      * 0x4 - Administrator
                      * 0x5 - OEM Proprietary
                      * 0xF - No Access

               test         <user id> <16|20> [<password]>

Upon listing the IPMI users for the mainboard, I found that the default admin account was actually assigned to user ID 2, not user ID 1.

kevin@temporary:~$ sudo ipmitool -I open user list
IANA PEN registry open failed: No such file or directory
ID  Name             Callin  Link Auth  IPMI Msg   Channel Priv Limit
1                    true    false      false      Unknown (0x00)
2   ADMIN            true    false      false      Unknown (0x00)
3   IPMI_USER        true    false      false      Unknown (0x00)
4                    true    false      false      Unknown (0x00)
5                    true    false      false      Unknown (0x00)
6                    true    false      false      Unknown (0x00)
7                    true    false      false      Unknown (0x00)
8                    true    false      false      Unknown (0x00)
9                    true    false      false      Unknown (0x00)
10                   true    false      false      Unknown (0x00)

ADMIN (user ID 2) appeared to be the default admin account and IPMI_USER (user ID 3) appeared to be an account added by the previous owner.

kevin@temporary:~$ sudo ipmitool -I open user set password 2 <insert new password here>
IANA PEN registry open failed: No such file or directory
Set User Password command successful (user 2)

Knowing that the default admin account was on user ID 2 instead of 1, I was able to successfully reset the admin password (which I redacted for privacy).

From there, I was successfully able to access the Web interface, where I changed the username and password for the other user account, though I could also just do it in the command line. I also found through there that user ID 1 is used for a hidden 'Anonymous' user, which I think was not present on older versions of AMI MegaRAC from prior to 2014 or thereabouts.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .