0

I recently upgraded to Zimbra 8.7. We provide clients Authenticated SMTP relay, but several have older Outlook apps that are not sending a valid HELO in their connection. In 7.x versions of Zimbra, the mta would fix this on the fly by adding the server's hostname to the end of the client HELO. This has stopped in 8.7 and I have been trying to find a way to enable this behavior.

For example, ESMTP helo=<Art> would become ESMTP helo=<Art@server.example.com> so servers with strict HELO rules would not bounce with "Invalid HELO address"

Does anyone know a setting for this in Zimbra/Postfix?

  • But your server is making the outbound SMTP connections and should use your server address. Is it not your server that is rejecting the invalid HELO's ? – Micha Kersloot May 29 '17 at 9:16
  • The helo=<Art> appears in the email's headers and some services are rejecting due to this. I't happening for 2 specific clients out of a few thousand that are using the same version of Outlook (2010 version). The previous versions of Zimbra's postfix would automatically correct this behavior, so I was hoping it was a setting I am missing. I know the internals of Zimbra quite well, but this one has got me stumped. – Gmck May 30 '17 at 12:50
0

Maybe the following commands can help you. It works for the ZWC, but you have to test if it works for relayed smtp mails:

Strip X-Mailer header

zmprov mcf zimbraSmtpSendAddMailer FALSE

Strip x-originating-ip-header:

zmprov mcf zimbraSmtpSendAddOriginatingIP FALSE

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.