1

We're having an odd issue with our Remote Desktop Services that we just can't seem to figure out. If we are testing from our internal network, we are able to hit the address and run the application just fine. However, if we try to hit it externally we get the following message.

Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable. Try reconnecting later or contact your network administrator for assistance

As a result, we're not able to even run the application when we're external. We have the terminal server setup in AWS behind an Elastic Load Balancer that is open to the internet. The server is hosting all of the necessary services (Connection Broker, Gateway, Web, Session Host) all on one box. We have verified that port 443 & 80 are open on the Elastic load balancer and from the load balancer to the server. We purchased a certificate and verified that it is properly binded to port 443 in IIS and in the Gateway Manager service. We've made sure that the users testing are part of the appropriate group that has access to the collection and have double checked that all the services are actively running when testing from external. We've also even tried opening up port 3389 just in case since I saw that on some forums online. At this point we're kind of drawing a blank as to why it only works in the intranet. The only other tidbit would be the URL for the site is going through Cloudflare. I can't see why that would block external users only though and not internal.

Does anyone have any clue what might be going on or has anyone run into any similar issues with Remote Desktop Services?

Any help would appreciated!

Let me know if you need anymore additional info or any logs

Thanks

0

Posting this just in case anyone runs into this issue with a terminal services setup in AWS behind an Elastic Load Balancer.

Our resolution was to disable SSL termination on the ELB, so instead of having HTTPS -> HTTPS on the load balancer, we set it up to TCP -> TCP on 443. That way it is doing SSL offloading instead of SSL termination. We also setup SSL bridging on the RD Gateway. We need to have the certificate on the local as part of the terminal services build out anyways, so this works for us.

Hopefully this helps other people!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.