3

I have installed pfsense in VirtualBox. I'm trying to access its configuration through my windows' browser but I cannot.

In the virtual machine's properties, I have tried to configure the WAN interface as bridge and as NAT, but none of them works. The details are below:

Windows

I am connected to my gateway routher through the Wireless adapter, so I have not connected the ethernet interfaze. My IP address in windows is: 192.168.1.34 / 24.

PfSense - WAN interface as NAT

I start PfSense. The WAN interface takes an IP address from DHCP, that address is 10.0.2.15 / 24. As you can see, that address is outside the windows' network, I do not understand why the DHCP service gives PfSense that IP.

Anyway, with the above address, I can ping both the reouter and the windows host, but I cannot do the same from windows to PfSense.

I have tried to set up the IP manually with an IP address that is inside the windows' subnet, for example 192.168.1.50 / 24. If I do that, I can't ping neither windows nor the router, and of course the same ocurrs if I trty to ping from windows to pfsense.

PfSense - WAN interface as bridge

With this configuration, DHCP does not give any IP to the PfSense's WAN interface, I have to put it manually. With thios configuration, I cannot ping PfSense from windows to PfSense, and the same for the opposite.

EDIT

I have tried another configuration:

I have connected the ethernet interface to the router, and the PfSense adapters as bridge.

I can ping from pfSense to windows and to the router, but I cannot ping from windows to pfSense.

2 Answers 2

1

As you said you have installed pfsense on virtualbox so the ip allocated to pfsense interface is issued by virtualbox DHCP service thats why you are getting 10.0.2.15 / 24 on pfsense, also bridging is not active/configured or not working on your host machine on which you installed virtualbox

First setup bridge on virtualbox and select proper bridge interface on which your are connected to your LAN network, once done you should be able to get ip address to your guest machine on virtualbox from your LAN dhcp server i.e 192.168.1.0/24, if still your not getting lan ip on pfsense guest then check if any mac address binding is active on your dhcp server which is not allocating ip to pfsense

If your using windows 10 then there are some known issues on bridging with virtualbox you can check this link for more details

Once you figure out the bridge then you can walk on pfsense

0

The same thing happened to me as well.

This is because pfSense blocks any private network on the WAN interface (10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16) by default.

In your case the wan IP Address is 10.0.2.15/24; so pfsense is blocking the access by default.

To resolve this we have to disable "Block private networks and loopback addresses" in the web GUI. And to access WebGUI you have to follow below steps.

In the pfSense Console (Shell), enter "pfctl -d" to disable "pf". This will only be temporary, pf will be re-enabled every time a change is made to the firewall rules.

Allow WAN access to port 443 with below command: "easyrule pass wan tcp any any 443" (you can change any any with your preferences)

Once you are able to access WebGUI do the following: (first run pfctl -d to disable the packet filter temporarily): Interfaces > WAN > Block private networks and loopback addresses + hit Apply Changes.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.