1

I need my website to be reachable from ipv6 for my ios app to be validated by apple. It was the case as I've been able to submit the first version of my app after following several tutorial to configure ipv6 but for some reason the server seems no more compatible with ipv6, and I don't find the problem. The domain is creforma.fr

Maybe it can help:

ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:07:cb:03:ae:e9
          inet addr:163.xxx.29.247  Bcast:163.172.29.255  Mask:255.255.255.0
          inet6 addr: 2001:xxx:2427:100::/56 Scope:Global
          inet6 addr: fe80::207:cbff:fe03:aee9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6493973 errors:0 dropped:0 overruns:1 frame:0
          TX packets:6107939 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:862938890 (822.9 MiB)  TX bytes:7704140929 (7.1 GiB)
          Memory:80000000-8001ffff

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1794 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1794 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:951370 (929.0 KiB)  TX bytes:951370 (929.0 KiB)

ping -c 1 localhost:

PING localhost (127.0.0.1) 56(84) bytes of data. 64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.033 ms

--- localhost ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev =
0.033/0.033/0.033/0.000 ms

ping6 -c 1 ip6-localhost:

PING ip6-localhost(localhost) 56 data bytes 64 bytes from localhost: icmp_seq=1 ttl=64 time=0.030 ms

--- ip6-localhost ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev =
0.030/0.030/0.030/0.000 ms

ping -c 1 ipv4.google.com:

PING ipv4.l.google.com (216.58.204.238) 56(84) bytes of data. 64 bytes from par21s06-in-f238.1e100.net (216.58.204.238): icmp_seq=1 ttl=58 time=0.779 ms

--- ipv4.l.google.com ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev =
0.779/0.779/0.779/0.000 ms

ping6 -c 1 ipv6.google.com:

PING ipv6.google.com(par21s06-in-x0e.1e100.net) 56 data bytes From par21s06-in-x0e.1e100.net icmp_seq=1 Destination unreachable: Address unreachable

--- ipv6.google.com ping statistics --- 1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

netstat -rn6:

Kernel IPv6 routing table
Destination                    Next Hop                   Flag Met Ref Use If
::1/128                        ::                         U    256 0     0 lo
2001:xxx:2427:100::/56         ::                         U    256 0     1 eth0
fe80::/64                      ::                         U    256 0     0 eth0
::/0                           2001:xxx:2427:1ff:ff:ff:ff:ff UG   1024 0     0 eth0
::/0                           ::                         !n   -1  1    24 lo
::1/128                        ::                         Un   0   1   228 lo
2001:xxx:2427:100::/128        ::                         Un   0   1    54 lo
fe80::207:cbff:fe03:aee9/128   ::                         Un   0   1     0 lo
ff00::/8                       ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1    24 lo

Thanks in advance

  • After a scan on www.ipv6scanner.com all ports are filtered for ipv6 is it the firewall ? – Entretoize May 23 '17 at 7:59
  • And you do have Listen [fe80::207:cbff:fe03:aee9]:80 in Apache's configuration? – Esa Jokinen May 23 '17 at 8:04
  • I have Listen [::]:80 – Entretoize May 23 '17 at 8:53
  • 2
    Listening on the link-local address doesn't make sense I this case. Listening on [::]:80 is correct. – Sander Steffann May 23 '17 at 15:52
  • 1
    What information did your provider give you about the IPv6 configuration? – Sander Steffann May 23 '17 at 15:53
0

First step you have to check your default route netstat -rn6 and try to ping them

  • I added the result of netstat -rn6 command to my post, how can I know which is the default ? – Entretoize May 23 '17 at 11:50
  • Destination is ::/0 or default ::/0 2001:bc8:2427:1ff:ff:ff:ff:ff UG 1024 0 0 eth0 – Scypi May 24 '17 at 11:54
  • So... it doesn't ping the default route – Entretoize May 25 '17 at 7:19
  • What @Sander Steffann says ask you ISP about configuration. You can also try autoconfiguration. Check that you have enable net.ipv6.conf.all.autoconf and net.ipv6.conf.all.accept_ra in sysctl and disabled net.ipv6.conf.all.forwarding. Then put iface eth0 inet6 auto in your /etc/network/interfaces and bring up interface – Scypi May 25 '17 at 10:46
  • iface eth0 inet6 auto killed the whole connection... – Entretoize May 25 '17 at 12:50
0

Since you are using Online hosting provider, did you carefully follow their tutorial: https://documentation.online.net/en/dedicated-server/network/ipv6/prefix ?

If not, you will have problems and any misconfiguration may trigger a protection on their network that will shutdown all your traffic, and you will need to contact their support team to lift it.

  • Yes, everything is well configured and it worked and without changing anything it stopped working. I have sshguard installed but even deactivating ip6tables the way described here: cyberciti.biz/faq/debian-iptables-stop the ports still seems filtered. – Entretoize May 27 '17 at 19:57
  • Then start from scratch, without sshguard and ip6tables and see if things work by just following the Online documentation. – Patrick Mevzek May 28 '17 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.