0

I created an virtual environment using proxmox for virtualisation with one VM for testing purposes and a pfsense vm. The pfsense has two network adapters. One for the WAN Interface and one for the LAN interface. I connected the VM and pfsense with an bridge vmbr1. That is working fine.

On the WAN interface I have another bridge vmbr1 which is connected to eth0. The bridges are configured as follows:

/etc/network/interfaces

auto lo
iface lo inet loopback

iface lo inet6 loopback

auto eth0
iface eth0 inet manual


auto vmbr0
iface vmbr0 inet static
    address  public_ip
    netmask  255.255.255.224
    gateway  inet_gateway
    bridge_ports eth0
    bridge_stp off
    bridge_fd 0
  # route public_ip/27 via inet_gateway
  up route add -net inet_getway netmask 255.255.255.224 gw inet_gateway dev eth0

auto vmbr1
iface vmbr1 inet static
        address  192.168.18.1
        netmask  255.255.255.0
        bridge_ports none
        bridge_stp off
        bridge_fd 0

What I want is an internet connection for the VMs with the pfsense firewall between internet and VMs. But I wasn't able to connect the pfsense with the internet with the public IP.

Do you have some suggestion to solve this problem?

Thanks in advance!

0

Configure the wan port of pfsense with a public IP and public gateway, or move the public IP from vmbr0(of proxmox) to pfsenseWANport.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.