0

So I'm having an issue where users can set the out of office for outlook, but response only go internally but not externally. Upon looking into the issue, it seems to be autodiscover. I noticed there is an expired certificate on the exchange, and a new certificate was installed as remote.blahblah.com.au, and the old was mail.blahblah.com.au. I noticed outlook anywhere was set to the old domain (mail.blahblah.com.au), so I corrected this (about 1 hr ago) to the new domain (remote.blahblah.com.au). I then noticed the _autodiscover SRV entry was set to the old domain (mail.blahblah.com.au), which I corrected too (to remote.blahblah.com.au). I understand I may need to wait for the DNS to update, but there is a remote.blahblah.com.au entry in the forward lookup zones which is missing an autodiscover A record and _tcp entry. There is an autodiscover A record and _tcp entry in the standard blahblah.com.au entry though, so my question is in order to get OOF working, do I need to stick an autodiscover A record and SRV entry in the remote.blahblah.com.au?

enter image description here

enter image description here

enter image description here

1

I'm having an issue where users can set the out of office for outlook, but response only go internally but not externally.

Does the externally here mean the same domain' user with external Outlook clients or the other domains' users?

Actually, it doesn't make sense that domain users can receive OOF email from internal clients but externals, unless the external Outlook connection is not established.

If the issue is about other domains' users cannot receive the OOF message from your domain, check the remote domain settings and make sure the Out of office message is allowed: Set-RemoteDomain -AllowedOOFType 'External' -Identity 'Default'

https://social.technet.microsoft.com/Forums/exchange/en-US/bd8fed14-dbf5-4f2c-bf8e-e4b0b5263624/out-of-office-not-working-for-external-users?forum=exchange2010

Besides, for external Outlook clients, when it tries to contact Autodiscover service, it would contact the autodiscover.SMTPAddresssuffix. For example, the email address is user1@contoso.com, we should have public DNS record autodiscover.contoso.com. I suppose you have correct external Autodiscover record. Keep in mind that the external clients will not be able to connect internal SCP(internal autodiscover URI).

Since the users are able to set OOF, then it would not be an Autodiscover issue. If the Autodiscover service doesn't work, Outlook client would be unable to contact the OOF service for setting. An valuable KB about Autodiscover service for your reference: https://technet.microsoft.com/en-us/library/jj591328%28v=exchg.141%29.aspx

1

The DNS entry for Autodiscover is completely unnecessary unless you have internal clients who are using Outlook but are NOT on the domain.

When a client is on the domain and is able to see the domain (ie it isn't outside the network) it doesn't even query the DNS entry.

The fix for this is to correct the entry on Exchange.

get-clientaccessserver | set-clientaccessserver -AutodiscoverServiceInternalURI https://host.example.com/Autodiscover/Autodiscover.xml

where host.example.com is the name on your SSL certificate, AND resolves internally to the Exchange server.

The SRV record would only be required outside and only if you do not have Autodiscover.example.com on the SSL certificate as one of the additional names.

  • "When a client is on the domain and is able to see the domain (ie it isn't outside the network) it doesn't even query the [autodiscover] DNS entry." This is not the case for domain-joined Outlook clients configured for Outlook Anywhere, even when they're on the internal network. I've consistently observed such clients querying autodiscover.example.com even though they should be doing an SCP lookup. – Twisty Impersonator Jun 15 '17 at 21:31
  • That means something is wrong with your setup, as that is not something I have ever seen. SCP is the first check and it will only do the other queries if the SCP fails. – Sembee Jun 16 '17 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.