2

We've recently installed 2 new Server 2016 Virtual machines while we're awaiting the licenses. We try to connect through RDP, but we cannot connect succesfully. When looking at the RDP options, we see the remote option is enabled, but greyed out. There's no group policy active for RDP on this domain.

I can only think that it won't work as long as the servers haven't been activated, but I cannot find any documentation on that.

2

From TechNet article Learn About Product Activation:

If activation does not occur immediately after the operating system is installed, Windows 7 and Windows Server 2008 R2 still provide the full functionality of the operating system for a limited amount of time, or grace period.

While the 30-day grace period has been removed since Windows 8 / Server 2012 and replaced with increased notifications and disabling personalization features, all the other features of the operating system still functions normally, so RDP even should be possible.

Licensed evaluation period of Server 2016 lasts 180 days. According to discussion on Spiceworks, a completely unactivated copy of 2008 and 2012 (& R2) runs 30 days (10 days for evaluation install) normally, and then starts shutting down once per hour. Probably 2016 does the same. However, that should be only theoretical as it doesn't take that long to get the actual licence. And it doesn't change that the OS is still otherwise fully functional.

Grayed out usually means there is a Group Policy affecting these settings. Review both your domain polixies and local group policies. I'd use Resultant Set of Policy MMC snap-in to see the affecting policy directly, regardless where the policy is set, as GPO inheritance may be complicated.

Expand Computer Configuration – Administrative Templates – Windows Components – Remote Desktop Services – Remote Desktop Session Host – Connections and check that Allow users to connect remotely using Remote Desktop Services is either Not configured or Enabled.

  • It seems it is indeed the local policy which has entries, but the "Allow users to connect to RDP" is enabled. However, this policy come from a GPO called "Windows SBS client policy" and as far as I remember, there's no SBS active anymore (replaced by a DC machine). Created those rules locally, executed gpupdate but still the result from rsop lists the SBS policy over the local one. But still, I should be able to connect, unless I'm missing something else? – Terry May 26 '17 at 12:14
  • There could be GPOs from SBS installation that should still be deleted from your GP as it's not automatic. Did you read through the RSoP it there is some other setting that could affect? Grayed out options are almost always caused by a group policy setting. – Esa Jokinen May 26 '17 at 12:21
  • I haven't found anything else. I did however did some logical thinking based on above feedback. If the gpo enabled my remote desktop, I didn't get the prompt to enable RDP in the windows firewall. So I checked that and it was the missing link. – Terry May 26 '17 at 12:57
  • I also found this post after searching some more based on your answer, which adds more information about the grace period for windows server 2016, maybe you can add some of that to your answer and I'll accept: community.spiceworks.com/topic/… – Terry May 26 '17 at 12:59
  • Good this was still helpful. I added some information on 2016 evaluation. – Esa Jokinen May 26 '17 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.