1

I'm trying to setup a HA storage with gluster. Share it with Samba so I can access it on Windows clients. CTDB for HA connection to the clients and OpenLDAP for user authentication. It's a virtual test setup which we maybe want to use for the company. All the VMs can ping eachother. I'm using CentOS 7.

  • Gluster node 1: 192.168.2.210
  • Gluster node 2: 192.168.2.211
  • LDAP server: 192.168.2.95
  • Windows client: 192.168.2.100 (Windows 10)

I got my gluster volume working (distributed replicated). I can't get CTDB failover and samba/openldap authentication to work. The ctdb config file, public_addresses and nodes files are located on my gluster volume and linked(symbolic) to /etc/sysconfig/ctdb, /etc/ctdb/public_addresses and /etc/ctdb/nodes.

/etc/sysconfig/ctdb > /gluster/lock/ctdb

CTDB_RECOVERY_LOCK=/gluster/lock/.CTDB-lockfile
CTDB_NODES=/etc/ctdb/nodes
CTDB_PUBLIC_ADDRESSES=/etc/ctdb/public_addresses
CTDB_MANAGES_SAMBA=yes

public_addessses > /gluster/lock/public_addresses

192.168.2.215/24 ens33

/etc/ctdb/nodes > /gluster/lock/nodes

192.168.2.210
192.168.2.211

/etc/samba/smb.conf

[global]
workgroup = WORKGROUP
security = user
passdb backend = tdbsam
idmap backend = tdb2
clustering = yes

[gluster-data]
vfs object = glusterfs
glusterfs:volume = data
glusterfs:logfile = /var/log/samba/glusterfs-data.%M.log
glusterfs:loglevel = 7
path = /gluster/share
read only = no
create mask = 0770
guest ok = yes
browseable = yes
writeable = yes

So first of all my CTDB is working the opposite way. I can only ping the floating IP-address when both nodes are online. 'ctdb status' says both nodes are OK and 'ctdb ip' shows the floating IP-address. When I try to access the volume on my Windows client I keep getting the error: 'The specified network password is not correct'. I did run smbpasswd -a 'testuser' on both nodes. Even root won't authenticate. So then I thought I could try OpenLDAP for user authentication. I changed the samba settings to:

/etc/samba/smb.conf

[global]
workgroup = WORKGROUP
security = user
passdb backend = ldapsam:ldap://192.168.2.95
idmap backend = ldap:ldap://192.168.2.95
ldap suffix = dc=domain,dc=com
ldap admin dn = cn=ldapadm,dc=domain,dc=com
clustering = yes

[gluster-data]
vfs object = glusterfs
glusterfs:volume = data
glusterfs:logfile = /var/log/samba/glusterfs-data.%M.log
glusterfs:loglevel = 7
path = /gluster/share
read only = no
create mask = 0770
valid users = @Users
force group = Users
guest ok = yes
browseable = yes
writeable = yes

With these settings I can't even ping the floating CTDB IP-address and ctdb status says the nodes are UNHEALTY. I also ran smbpasswd -W 'ldapadm password'. Using a CentOS client I can log in to the OpenLDAP user.

I'm fairly new to all this and english isn't my native language so sorry for any mistakes. I hope someone can help me and can provide more information if I didn't give all that's needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.