I just installed a Windows 2008 Server on a HP proliant DL180 G5. Since I have installed and setup correctly WSUS 3.0 SP2 for my domain, I am not able to download Windows Update from the Windows update web site.

I always get the error message: 80244019 (Windows Update encountered an unknown error.)

I tried to set and as DNS - No luck I tried checking the Registry [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU] but no luck again because I don't have \WindowsUpdate\AU.

Is anyone know what should I do to be able to access Windows Update website from this server?

My OS is: Windows 2008 Server SP2. Intel Xeon E5420 2.5Ghz 4GO Ram 2x HDD 160Go RAID1

Regards, David.


How do you try to download the windows updates? I'm pretty sure you have to download the updates from the WSUS 3.0 SP2 MMC Snapin and deploy them from there.

I dont think it's possible to download and install updates directly from microsoft on a server running WSUS.

  • That's a pretty interesting answer! I tought it was possible because WSUS downloads all the updates from WindowsUpdate.com... My 2008 server is not listed in the OU on which I push the WSUS GPO. So basicaly, if I understand, my 2008 server cannot be updated unless I have another WSUS server update my actual WSUS server? Or, download updates one by one, manually from Microsoft. I think about this and it just doesn't make any sense to me... – r0ca Nov 16 '09 at 23:13
  • Hi The WSUS Server should be able to download all updates from WindowsUpdate.com. I mean that it's not possbile for the local WSUS Client to download the updates. Are the download and proxy settings in the WSUS server correct? I think you have to configure the WSUS Client of your WSUS Server to point to itself. You can configure the WSUS Client by editing the registry of the server or you create a new gpo for this server only. technet.microsoft.com/en-us/library/cc708449%28WS.10%29.aspx I've to admit I just cant test it out this week because i'm on the run and not in my office. – grub Nov 17 '09 at 7:04
  • This is probably something I might try since I need to fix this issue before friday night. I'll give it a try and let you know. So far, your help was really helpfull! Regards! David. – r0ca Nov 17 '09 at 13:29

WSUS Install Docs

I followed this, specifically on the requirements and permissions, and I got passed this error.


You just have to delete the following Registry Key:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.