• Server: Windows 2008 Server Standard SP2 with "Terminal Services" role

  • Clients: Windows XP SP3 + .NET 3.5 Framework SP1 + Remote Desktop Client 7.0

We are using "Easy Print" feature which allows programs running on server to "see" printers installed on client machines. Everything works fine, EXCEPT when we send a text-only output to a dot-matrix printer. In this case, the printer only outputs a blank page.

At first, we had problems with the error "Windows Presentation Foundation Terminal Server Print W has encountered a problem and needs to close." but this was fixed by replacing TsWpfWrp.exe with the one from Vista SP1 as suggested here.

But now, we only get a blank page! Every other (graphical) document we sent to printer works 100%.

We also tried to use the "Generic text-only" driver, but the result is same.

Now we are trying to change parameters like print processor on "advanced" tab from printer driver to see if something happen. But this is just guessing and we really don't know what to try anymore.

The problem appears to be on Easy Print driver, but we found almost no resources about it. Any tips are welcome.

  • What kind of printer is it? Are you using the IBM Pro Printer driver?? – user71966 Feb 24 '11 at 3:24

I found Easy Print alwas to be slow. Also it will always produce graphical output. If you need text only printing, do these two things:

  1. Enable use of native drivers : in Group Policy disable Use Terminal Services Easy printer driver first, this is located in User Configuration/Policies/Administrative Templates/Windows Components/Terminal Services/Terminal Server/Printer Redirection
  2. Install the native printer driver on the Server (the version number and the name of the driver must be the same on the server and the client)

Try uninstalling...

  • windows.net framework 3.5
  • .net framework 3.0
  • .net framework 2.0

And then reinstall...

  • .net framework 3.5

From here.


I find Easy Print very slow (generates huge files) and non-compatible with host-based printers. As already suggested, disable "Use easy print driver first" on the server and install native printer driver on server. Then disconnect the terminal session by logging off, reconnect, make sure native driver is used by checking the printer properties on terminal server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy