I set up a share in Windows Server 2008, giving full rights to my domain account.

The share was perfectly accessible for about a week, then today I could no longer access it from my Windows XP machine. I tried:

  1. Flushing my dns and navigating to //machinename/sharename - resulted in not accessible msg
  2. Navigating to //machine ip address/sharename - resulted in not accessible msg
  3. Pinging machine IP address - successful
  4. Pinging machine name - successful

Shortly thereafter, I tried to access the share via a Windows 7 machine, and it worked perfectly! Please note, I was logged into the WinXP and Win7 machine with the same domain account.

So, my question is what could cause a a Windows Server 2008 box to successfully share with Win7 and not WinXP?

I know that Microsoft re-wrote the network stack after WinXP, so I thought maybe WinXP calls into these shares differently than Win7. Maybe just that service (or whatever) providing legacy access for WinXP crashed?

A reboot fixed the problem for WinXP, but I'd really like to avoid this if possible.

Update I still have not found a real resolution to this issue. For now rebooting is my only fix. Fortunately, I haven't run into this in a couple weeks.


We've seen the same symptoms with Server 2008 network shares running on boxes with older revisions of Symantec anti-virus products. If you have SAV or SEP 11, make sure the box is running the latest Maintenence Release.

  • Thanks Bob! I just checked and the SAV is out of date on that machine. I can't replicate this on demand, so only time will tell. But this certainly seems plausible. – reustmd Dec 4 '09 at 22:42

So, for troubleshooting purposes, mostly in an environment that has mixes operating systems, you might want to consider disabling SMB 2.0. You need to do so on both the "client" and the "server" operating systems.

To disable SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled

Note there's an extra " " (space) after the "=" sign.

To enable back SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc config mrxsmb20 start= auto

Again, note there's an extra " " (space) after the "=" sign.

In order to disable SMB 2.0 on the server-side computer, follow these steps:

  • Run "regedit" on Windows Server 2008 based computer.
  • Expand and locate the sub tree as follows. HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
  • Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
    Value name: Smb2
    Value type: REG_DWORD
      0 = disabled
      1 = enabled
  • Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
  • Reboot the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.