1

Trying to compile apache2.4.25 from source on Fedora 15 with dynamically linked mod_ssl. Fedora15 server has a default openssl version (OpenSSL 1.0.0j-fips 10 May 2012) and newer openssl library (OpenSSL 1.0.2g 1 Mar 2016) is installed in /usr/local/ssl/bin.

Compilation steps

./configure --enable-ssl=shared --with-ssl=/usr/local/ssl/lib --with-pcre=/usr/local/pcre/lib/pcre-config

make 
make install

After installation, shared library is still pointing to older openssl version

ldd /usr/local/apache2/modules/mod_ssl.so
    libssl.so.10 => /usr/lib64/libssl.so.10 (0x00007fb715087000)

ls -lrt  /usr/lib64/libssl.so.10
lrwxrwxrwx 1 root root 16 Jun  2 14:43 /usr/lib64/libssl.so.10 -> libssl.so.1.0.0j

libssl.s0.10 has a sym link to system default openssl version. Tried compiling without specific custom path to openssl library and still the same results with libssl.so still pointing to system openssl version.

Even tried setting the LD_LIBRARY_PATH env variable to point to new openssl lib path, yet no luck.

  • if your dir with the new libs is /mynewlibs and it contains four libs: libssl.so -> libssl.so.10, libssl.so.10, libcrypto.so -> libcrypto.so.10, libcrypto.so.10,then after invoking in the same shell export LD_LIBRARY_PATH=/mynewlibs/ you will have your ldd output pointed top the right libs – Oleg Jun 3 '17 at 12:55
1

Solved this issue by deleting the old OpenSSL library(_libssl.so.10_) and recompiling with the latest OpenSSL library.

Once this was installed, copied the older _libssl.so_ file back to the directory it was initially in. This has solved the issue for now, but not recommended on a production server :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.