10

I can't get the Supermicro IPMIView version 2.* (any of them) to launch the KVM Console either in the IPMIView windows program nor any browser. Java, is installed (version 8, update 131) and I'm running Windows 8.1 (though IPMIView 2 won't run on my Windows 7 laptop, nor any of the Windows 10 machines). All 3 machines have the same problem: The KVM Console simply will not run on any of them. I can connect to the Supermicro server, turn it off/on/reboot, read all of the sensors just fine. The ONLY thing not working is the KVM Console.

Been at this for days w/no working solutions.

I've uninstalled Java, reinstalled Java, uninstalled/reinstalled IPMIView with no luck so I'm thinking the problem is with all of the SM servers (4) that run w/the H8SGL-F series motherboards. Not one works! As per SuperMicro, IPMIView is supposed to be compatible with these boards. But for the last 5 years and countless versions, I've never had this working (it also will not work in any of my browsers as IPMIView appears to be looking for an ancient version of Java - go figure - I get the error message in the browser "You need the latest Java(TM) Runtime Environment. Would you like to update now?" - which is incorrect as I have the latest version of Java installed). I've made 1000% certain that ALL ports on the network (inside an IPSec VPN) are open - disabled all firewalls with no effect. Either IPMIView is incompatible with these boards, or IPMIView cannot run in an IPSec tunnel.

Regardless, this is driving me bonkers and I'd hate to abandon SuperMicro products (we're replacing all the servers this year - may go with IBM or HP) over something so ridiculously simple.

Any help is appreciated (we tried paid help, but the IT people here are just as stumped).

8
  • A side note since you are stating that you are about to replace the servers: No need to switch vendors, current SuperMicro IPMI have HTML5 remote consoles ... no need to keep deprecated Java around anymore. Jun 6, 2017 at 6:35
  • What year were those servers purchased? Jun 6, 2017 at 6:39
  • 2011 - 2012 They still sell the H8SGF-F motherboards today as they are the only single socket Opteron 6000 series boards on the market. We can move to Intel boards, but I fear we'll have the same problem - crappy management software that stops working after 1 year (IPMIView KVM Console DID work, then, suddenly stopped working - ugh!)
    – DaveN
    Jun 6, 2017 at 6:54
  • Since it will be 6 months until new servers are bought - I suppose I can just live with SMs nightmare a bit longer.
    – DaveN
    Jun 6, 2017 at 6:56
  • 2011 the Java7 was the current version. Try installing the latest Java7 JRE and use it to run the console. Jun 6, 2017 at 7:05

6 Answers 6

10

Better answer and complete solution. The problem was the firmware for the IPMI on these boards was too old (not the same as the BIOS - updating the BIOS will not help in this case). Digging around SuperMicro's site (never did get a reply from them), I found the Firmware Revision of 3.20 & was able to install it. On the IPMI device tab, under "Device Information", you should see: Firmware Revision 3.20 IPMI Revision: 2.0 I can now see the KVM Console in both the IPMIView software and the browser (all of them) and still run the latest version of Java in the OS (Win8.1 and Win10). Maybe I'm blind, but I never did see this solution on SuperMicro's website.

1
  • 4
    I had to run IPMIView as Administrator, which is (a) weird and (b) a little troubling. Unfortunately, no upgrade exists for my IPMI firmware, so no HTML5 interface. At least it can be run inside a dedicated/throw-away VM. Nov 21, 2018 at 21:10
3

These old IPMI are problematic. What I do is:

This combination worked for my case;

1

I have been having this issue and thought something wrong with the Java somewhere, after digging into it I have found this solution

Your Java installation \lib\security\java.security

Comment out "jdk.tls.disabledAlgorithms=SSLv3"

Save the file and boom! It is working :)

1
  • 3
    Warning: This causes SSLv3 to be enabled, which may put you at risk. It's better to update the IPMI firmware, if possible. If it's not possible, then the server is probably too old to still be in production. Nov 25, 2018 at 16:39
0

Try using Firefox 50. I have a similiar issue with Lenovo's IMM. My KVM stuff depends on NPAPI plugins which are no longer supported in Chrome, and have recently been given additional limitations in the latest version of Firefox.

2
  • I'm setting up a VM with Windows XP and the old version of Firefox and see what happens. I don't understand why they can't just write Windows programs in native code (all the Win graphic and network libraries are already written & fully available - so why reinvent the wheel with Java?)
    – DaveN
    Jun 6, 2017 at 7:06
  • Chrome has some releases in an 'extended support' branch. It takes a few minutes to find, but we've been able to use this to extend our ability to use java beyond the mobo manufacturers leaving us high and dry. Jul 29, 2018 at 21:20
0

On Mac the jnlp console and sol files provided by the web-interface freeze. However if there linux ipmiview is running in background they run just fine.

0

This article in this blog helped me https://grenville.wordpress.com/2023/05/14/using-ipmiview-with-old-supermicro-bmcs/

I am just going to copy and paste his content here as answer since URLs might expire.

I tested the following under Windows 10

IPMIView_2.21.0_build.221118_Windows.zip https://www.supermicro.com/wdl/utility/IPMIView/Windows/IPMIView_2.21.0_build.221118_Windows.zip

unzips to reveal an installer app. Running the installer results in IPMIView being unpacked under “Program Files/SUPERMICRO/IPMIView“.

Append the following three lines to IPMIView’s built-in java environment’s java.security file at “Program Files/SUPERMICRO/IPMIView/jre/conf/security/java.security“:

jdk.certpath.disabledAlgorithms= jdk.jar.disabledAlgorithms= jdk.tls.disabledAlgorithms=

The blank after each “=” is intentional. This nullifies whatever list of algorithms were disabled earlier in the java.security file (because the java.security file is parsed in-order), thus re-allowing all algorithms.

Use “Run as Administrator” to launch the IPMIView app. You should now be able to successfully launch and use the “KVM Console” tab.

Note: This solution re-introduces old and insecure security protocols, but only within the context of IPMIView itself. We’re not altering the Window system’s java installation (assuming you even have one).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .