3

Issue

I am setting up a RHEL 6.X server to house my RabbitMQ test environment. I need to install Erlange 16 or higher to work correctly with the latest version of RabbitMQ (3.6.x I believe). However, I currently have Erlang 14 on the system. I tried to remove it via yum however yum is saying it is not installed.

yum remove erlang

However when I run

$ erl -v

I get the following

Erlang R14B04 (erts-5.8.5) [source] [64-bit] [rq:1] [async-threads:0] [kernel-poll:false]

Eshell V5.8.5  (abort with ^G)

And there exists a erlang directory

/usr/lib64/erlang/

With the following sub directories

bin  erts-5.8.5  lib  man  releases  usr

How should I go about uninstalling this version of Erlang so I can install a new version? One peice of information that may be helpful. After the first successful install of the old version I actually did run yum remove and it appeared to work. However when I then tried to install the newer version it was stating the conflicts and I then found the aforementioned directory.

3

erlang is made up of a number of RPM packages which are installed automatically as depependencies when you do yum install erlang. One of these packages contains the erl script.

However when you do yum remove erlang the additional packages aren't automatically removed.

You can remove all the packages by looking at yum's history (using the yum history list command - see https://unix.stackexchange.com/questions/303754/how-to-remove-all-installed-dependent-packages-while-removing-a-package-in-cento for more details) and removed the packages installed as part of the erlang installation transaction.

Or, in this case, you could probably just get a list of installed erlang components using yum list installed | grep erlang and remove those packages.

2

I had the same problem. yum list installed | grep erlang shows the installed erlang packages which can then be removed with yum remove erlang-*

1

uninstall erlang by yum need to do like this: first, find out erlang-erts by

yum list installed | grep erlang-erts

to see what is you erts full name then

yum remove erlang-erts.x86_64

it should remove erlang from yum

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.