1

I have set up a private network at work using a rasperry pi as the wireless access point. All of my wireless devices are able to connect to the network and communicate (via wlan0), however I have a Philips Hue hub that only has an ethernet port. I would like to, for example, use my phone (at 192.168.0.x) to command the hub (192.168.1.x:80) to change colors.

/etc/network/interfaces:

auto lo
    iface lo inet loopback

allow-hotplug eth0
    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.0.0
    network 192.168.1.0
    gateway 192.168.0.0

allow-hotplug wlan0
    iface eth0 inet static
    address 192.168.0.1
    netmask 255.255.0.0
    network 192.168.0.0

/etc/dnsmasq.conf:

interface=wlan0
    dhcp-range=192.168.0.2,192.168.0.20,255.255.255.0,24h
interface=eth0
    dhcp-range=192.168.1.2,192.168.1.20,255.255.255.0,24h

Also in /etc/dhcpcd.conf I have included the line

denyinterfaces wlan0

I have done a lot of research and read into forwarding with iptables (NAT), bridging using a third interface... I just have not found anyone with a problem similar to mine that deals with a wireless access point and eth0 connection in one box.

What would be the best way to accomplish my task? I would appreciate any guidance on this topic. Also, are my subnet masks and gateways set up correctly? Thanks!

0

You should enable ip forwarding on your RaspberryPi sysctl -w net.ipv4.ip_forward=1 and configure routing properly. E.g. your devices from network 192.168.0.0/24 should know the way to 192.168.1.0/24 and all devices from 192.168.1.0/24 should know way to 192.168.0.0/24.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.