0

I have installed SSL certificate on my domain but when opening the https://mail.imm.co.kr/owa in chrome browser, it is showing security error. I tried to check across internet but could not find a fix. Please help me.

Your connection is not private

Attackers might be trying to steal your information from mail.imm.co.kr (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID

Screenshot

  • To delete a question you can use the "Delete" link right under your question. There is however no need to delete it. If the answer below solved your problem you should accept it. – Gerald Schneider Aug 7 '17 at 12:03
1

The issue is caused by your SSL certificate installed is not valid for subdomains under the imm.co.kr.

The certificate is for:

  • imm.co.kr
  • immpe.com

What you need is to either have a certificate that includes mail.imm.co.kr or a wildcard certificate that covers *.imm.co.kr.

You should also fix your ciphers, and enable TLS 1.2 + disable SSL2 and SSL3 at the very least, as the connection can be downgraded and attacked rendering the SSL connection insecure.

See https://www.ssllabs.com/ssltest/analyze.html?d=mail.imm.co.kr for more information and recommendations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.