0

I apologize for my Linux knowledge which is really basic. I'm troubleshooting since a few hours trying different approaches but I'm still failing.

When I try the following instruction:

yum --enablerepo=remi,remi-test  install phpMyAdmin --skip-broken

I get this error message. And if I do update PHPMyAdmin just by decompressing the files it simply doesn't work. Can you explain me what this error is saying to me? Maybe I need that dependencies to be updated?

Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.denit.net
 * city-fan.org: nervion.us.es
 * epel: ftp.nluug.nl
 * extras: mirror.denit.net
 * remi: remi.mirror.wearetriple.com
 * remi-safe: remi.mirror.wearetriple.com
 * remi-test: remi.mirror.wearetriple.com
 * rpmforge: ftp.nluug.nl
 * updates: mirror.nforce.com
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.7.1-1.el6.remi will be installed
--> Processing Dependency: php-composer(tecnickcom/tcpdf) < 7 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) < 3 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/sql-parser) < 5 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/shapefile) < 3 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/motranslator) < 4 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(google/recaptcha) < 2 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(tecnickcom/tcpdf) >= 6.2 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) >= 2.0 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/sql-parser) >= 4.1.2 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/shapefile) >= 2.0 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(phpmyadmin/motranslator) >= 3.0 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(google/recaptcha) >= 1.1 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php(language) >= 5.5 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-xmlwriter for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-xml for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-recode for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-mysqli for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-mbstring for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-gd for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-composer(fedora/autoloader) for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-48.el6_8 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php-gmp for package: php-phpseclib-2.0.6-1.el6.remi.noarch
--> Processing Dependency: php-json for package: php-tcpdf-6.2.13-1.el6.remi.noarch
--> Processing Dependency: php-json for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-json for package: php-google-recaptcha-1.1.3-1.el6.remi.noarch
--> Processing Dependency: php-zip for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php-common(x86-64) = 5.3.3-48.el6_8 for package: php-5.3.3-48.el6_8.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-48.el6_8 for package: php-cli-5.3.3-48.el6_8.x86_64
---> Package php-common.x86_64 0:5.6.30-2.el6.remi will be an update
---> Package php-fedora-autoloader.noarch 0:1.0.0-1.el6.remi will be installed
---> Package php-gd.x86_64 0:5.6.30-2.el6.remi will be installed
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: libXpm.so.4()(64bit) for package: php-gd-5.6.30-2.el6.remi.x86_64
---> Package php-google-recaptcha.noarch 0:1.1.3-1.el6.remi will be installed
---> Package php-mbstring.x86_64 0:5.6.30-2.el6.remi will be installed
---> Package php-mysqlnd.x86_64 0:5.6.30-2.el6.remi will be installed
--> Processing Dependency: php-pdo(x86-64) = 5.6.30-2.el6.remi for package: php-mysqlnd-5.6.30-2.el6.remi.x86_64
---> Package php-phpmyadmin-motranslator.noarch 0:3.3-1.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/expression-language) < 4 for package: php-phpmyadmin-motranslator-3.3-1.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/expression-language) >= 2.8 for package: php-phpmyadmin-motranslator-3.3-1.el6.remi.noarch
---> Package php-phpmyadmin-shapefile.noarch 0:2.1-1.el6.remi will be installed
---> Package php-phpmyadmin-sql-parser.noarch 0:4.1.7-1.el6.remi will be installed
---> Package php-phpseclib.noarch 0:2.0.6-1.el6.remi will be installed
--> Processing Dependency: php-bcmath for package: php-phpseclib-2.0.6-1.el6.remi.noarch
---> Package php-recode.x86_64 0:5.6.30-2.el6.remi will be installed
--> Processing Dependency: librecode.so.0()(64bit) for package: php-recode-5.6.30-2.el6.remi.x86_64
---> Package php-tcpdf.noarch 0:6.2.13-1.el6.remi will be installed
--> Processing Dependency: php-tidy for package: php-tcpdf-6.2.13-1.el6.remi.noarch
--> Processing Dependency: php-posix for package: php-tcpdf-6.2.13-1.el6.remi.noarch
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.13-1.el6.remi will be installed
--> Processing Dependency: dejavu-sans-fonts for package: php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.remi.noarch
---> Package php-xml.x86_64 0:5.6.30-2.el6.remi will be installed
--> Running transaction check
---> Package dejavu-sans-fonts.noarch 0:2.33-1.el6 will be installed
--> Processing Dependency: dejavu-fonts-common = 2.33-1.el6 for package: dejavu-sans-fonts-2.33-1.el6.noarch
---> Package gd-last.x86_64 0:2.2.4-1.el6.remi will be installed
--> Processing Dependency: libwebp.so.5()(64bit) for package: gd-last-2.2.4-1.el6.remi.x86_64
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be installed
---> Package php.x86_64 0:5.3.3-48.el6_8 will be updated
--> Processing Dependency: php(x86-64) = 5.3.3-48.el6_8 for package: php-devel-5.3.3-48.el6_8.x86_64
---> Package php.x86_64 0:5.6.30-2.el6.remi will be an update
---> Package php-bcmath.x86_64 0:5.6.30-2.el6.remi will be installed
---> Package php-cli.x86_64 0:5.3.3-48.el6_8 will be updated
---> Package php-cli.x86_64 0:5.6.30-2.el6.remi will be an update
---> Package php-gmp.x86_64 0:5.6.30-2.el6.remi will be installed
---> Package php-pdo.x86_64 0:5.6.30-2.el6.remi will be installed
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be updated
---> Package php-pecl-memcache.x86_64 0:3.0.8-2.el6.remi.5.4 will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
---> Package php-pecl-zip.x86_64 0:1.14.0-0.2.20170301dev.el6.remi.5.6 will be installed
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.14.0-0.2.20170301dev.el6.remi.5.6.x86_64
---> Package php-process.x86_64 0:5.6.30-2.el6.remi will be installed
---> Package php-symfony3-expression-language.noarch 0:3.2.9-1.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/cache) = 3.2.9 for package: php-symfony3-expression-language-3.2.9-1.el6.remi.noarch
---> Package php-tidy.x86_64 0:5.6.30-2.el6.remi will be installed
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy-5.6.30-2.el6.remi.x86_64
---> Package recode.x86_64 0:3.6-28.1.el6 will be installed
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed
--> Running transaction check
---> Package dejavu-fonts-common.noarch 0:2.33-1.el6 will be installed
--> Processing Dependency: fontpackages-filesystem for package: dejavu-fonts-common-2.33-1.el6.noarch
---> Package libtidy.x86_64 0:0.99.0-34.20091203.0.el6 will be installed
---> Package libwebp.x86_64 0:0.4.3-3.el6 will be installed
---> Package libzip5.x86_64 0:1.2.0-1.el6.remi will be installed
---> Package php-devel.x86_64 0:5.3.3-48.el6_8 will be updated
---> Package php-devel.x86_64 0:5.6.30-2.el6.remi will be an update
--> Processing Dependency: php-pecl-jsonc-devel(x86-64) for package: php-devel-5.6.30-2.el6.remi.x86_64
---> Package php-pecl-memcache.x86_64 0:3.0.8-2.el6.remi.5.4 will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
---> Package php-symfony3-cache.noarch 0:3.2.9-1.el6.remi will be installed
--> Processing Dependency: php-symfony3-common = 3.2.9-1.el6.remi for package: php-symfony3-cache-3.2.9-1.el6.remi.noarch
--> Processing Dependency: php-composer(psr/log) < 2.0 for package: php-symfony3-cache-3.2.9-1.el6.remi.noarch
--> Processing Dependency: php-composer(psr/cache) < 2.0 for package: php-symfony3-cache-3.2.9-1.el6.remi.noarch
--> Processing Dependency: php-composer(psr/log) >= 1.0 for package: php-symfony3-cache-3.2.9-1.el6.remi.noarch
--> Processing Dependency: php-composer(psr/cache) >= 1.0 for package: php-symfony3-cache-3.2.9-1.el6.remi.noarch
--> Running transaction check
---> Package fontpackages-filesystem.noarch 0:1.41-1.1.el6 will be installed
---> Package php-PsrLog.noarch 0:1.0.2-2.el6.remi will be installed
---> Package php-pecl-jsonc-devel.x86_64 0:1.3.10-2.el6.remi.5.6 will be installed
---> Package php-pecl-memcache.x86_64 0:3.0.8-2.el6.remi.5.4 will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64
---> Package php-psr-cache.noarch 0:1.0.1-3.el6.remi will be installed
---> Package php-symfony3-common.noarch 0:3.2.9-1.el6.remi will be installed
--> Running transaction check
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
---> Package php-pecl-memcache.x86_64 0:3.0.8-2.el6.remi.5.4 will be an update
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-48.el6_8 will be updated
---> Package php-common.x86_64 0:5.6.30-2.el6.remi will be an update
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-process-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-gmp-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-mbstring-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-gd-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-xml-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-recode-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-pdo-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-tidy-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-cli-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-bcmath-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-zip-1.14.0-0.2.20170301dev.el6.remi.5.6.x86_64
--> Processing Dependency: php(zend-abi) = 20131226-64 for package: php-pecl-jsonc-1.3.10-2.el6.remi.5.6.x86_64
--> Processing Dependency: php(language) >= 5.4 for package: php-phpmyadmin-shapefile-2.1-1.el6.remi.noarch
--> Processing Dependency: php(language) >= 5.5.9 for package: php-symfony3-common-3.2.9-1.el6.remi.noarch
--> Processing Dependency: php(language) >= 5.5 for package: phpMyAdmin-4.7.1-1.el6.remi.noarch
--> Processing Dependency: php(language) >= 5.5 for package: php-google-recaptcha-1.1.3-1.el6.remi.noarch
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-zip-1.14.0-0.2.20170301dev.el6.remi.5.6.x86_64
--> Processing Dependency: php(api) = 20131106-64 for package: php-pecl-jsonc-1.3.10-2.el6.remi.5.6.x86_64
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-48.el6_8 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
---> Package php-common.x86_64 0:5.6.30-0.1.RC1.el6.remi will be an update
---> Package php-common.x86_64 0:5.6.30-2.el6.remi will be an update
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-process-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-gmp-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-mbstring-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-gd-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-xml-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-recode-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-pdo-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-tidy-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-cli-5.6.30-2.el6.remi.x86_64
--> Processing Dependency: php-common(x86-64) = 5.6.30-2.el6.remi for package: php-bcmath-5.6.30-2.el6.remi.x86_64
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be updated
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-memcache-3.0.5-4.el6.x86_64
--> Running transaction check
---> Package php-devel.x86_64 0:5.3.3-48.el6_8 will be updated

Packages skipped because of dependency problems:
    dejavu-fonts-common-2.33-1.el6.noarch from base
    dejavu-sans-fonts-2.33-1.el6.noarch from base
    fontpackages-filesystem-1.41-1.1.el6.noarch from base
    gd-last-2.2.4-1.el6.remi.x86_64 from remi
    libXpm-3.5.10-2.el6.x86_64 from base
    libtidy-0.99.0-34.20091203.0.el6.x86_64 from city-fan.org
    libwebp-0.4.3-3.el6.x86_64 from epel
    libzip5-1.2.0-1.el6.remi.x86_64 from remi
    php-5.6.30-2.el6.remi.x86_64 from remi-test
    php-PsrLog-1.0.2-2.el6.remi.noarch from remi
    php-bcmath-5.6.30-2.el6.remi.x86_64 from remi-test
    php-cli-5.6.30-2.el6.remi.x86_64 from remi-test
    php-common-5.6.30-0.1.RC1.el6.remi.x86_64 from remi-test
    php-common-5.6.30-2.el6.remi.x86_64 from remi-test
    php-devel-5.6.30-2.el6.remi.x86_64 from remi-test
    php-fedora-autoloader-1.0.0-1.el6.remi.noarch from remi
    php-gd-5.6.30-2.el6.remi.x86_64 from remi-test
    php-gmp-5.6.30-2.el6.remi.x86_64 from remi-test
    php-google-recaptcha-1.1.3-1.el6.remi.noarch from remi
    php-mbstring-5.6.30-2.el6.remi.x86_64 from remi-test
    php-mysqlnd-5.6.30-2.el6.remi.x86_64 from remi-test
    php-pdo-5.6.30-2.el6.remi.x86_64 from remi-test
    php-pecl-jsonc-1.3.10-2.el6.remi.5.6.x86_64 from remi-test
    php-pecl-jsonc-devel-1.3.10-2.el6.remi.5.6.x86_64 from remi-test
    php-pecl-memcache-3.0.8-2.el6.remi.5.4.x86_64 from remi
    php-pecl-zip-1.14.0-0.2.20170301dev.el6.remi.5.6.x86_64 from remi-test
    php-phpmyadmin-motranslator-3.3-1.el6.remi.noarch from remi
    php-phpmyadmin-shapefile-2.1-1.el6.remi.noarch from remi
    php-phpmyadmin-sql-parser-4.1.7-1.el6.remi.noarch from remi
    php-phpseclib-2.0.6-1.el6.remi.noarch from remi
    php-process-5.6.30-2.el6.remi.x86_64 from remi-test
    php-psr-cache-1.0.1-3.el6.remi.noarch from remi
    php-recode-5.6.30-2.el6.remi.x86_64 from remi-test
    php-symfony3-cache-3.2.9-1.el6.remi.noarch from remi
    php-symfony3-common-3.2.9-1.el6.remi.noarch from remi
    php-symfony3-expression-language-3.2.9-1.el6.remi.noarch from remi
    php-tcpdf-6.2.13-1.el6.remi.noarch from remi
    php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.remi.noarch from remi
    php-tidy-5.6.30-2.el6.remi.x86_64 from remi-test
    php-xml-5.6.30-2.el6.remi.x86_64 from remi-test
    phpMyAdmin-4.7.1-1.el6.remi.noarch from remi
    recode-3.6-28.1.el6.x86_64 from base
    t1lib-5.1.2-6.el6_2.1.x86_64 from base
1

1/ you obviously don't need "remi-test"

2/ you need at least PHP 5.6 to get the latest phpMyAdmin version (as explained)

So try:

yum --enablerepo=remi,remi-php56  install phpMyAdmin

If you don't want to upgrade PHP, and keep default version 5.3.3 from base repository, you have to keep old phpMyAdmin version available in EPEL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.