There is an issue with NFSv4 when you try to mount a path containing a space and or a bracket character. NFSv3 works fine using the path that uses a symbolic link to the actual folder and NFSv4 does not. I am unable to change the Dropbox installation path without different issues so it must remain as it is. Below are the configurations and the results of what I've tried.

NFS Server:
Debian 8.4
NFS Client:
RHEL 7.2

The server has Dropbox installed which creates a symbolic link like below:

/home/USER_ACCOUNT/Dropbox (corp)/

Path exported on server: (I've tried using the full path and the results are the same so I'm using the symbolic link in the example below)


Path in client's fstab:

XXX.XXX.XXX.XXX:/home/USER_ACCOUNT/Dropbox/040(corp)/HOSTXX_BACKUP/GUESTXX_BACKUP /nfs_mount nfs4     rw,bg,hard,nointr,rsize=32768,wsize=32768,tcp,actimeo=0,timeo=600 0 0

On the client mounting I was able to get past using the space by replacing it like below:

/home/USER_ACCOUNT/Dropbox (corp)/

Now the client returns the following error:

mount.nfs4: mounting XXX.XXX.XXX.XXX:/home/USER_ACCOUNT/Dropbox/040(corp)/HOSTXX_BACKUP/GUESTXX_BACKUP failed, reason given by server: No such file or directory

When I take that path and try to cd into it on the server it looks to get stuck at the bracket character and returns the following error:

-bash: syntax error near unexpected token `('

As of yet I have not been able to find a way to handle the bracket character. When I try using the standard escape sequences in /etc/fstab when it mounts, it truncates everything after the escaping slash.

I also tried "mount -d bind" without success. Both the new folder and the original paths (absolute and symbolic) then appear to be empty like the data disappeared until I reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.