This is a brand new installation I am trying to provision the first SSP for MOSS and I keep getting the following error:

(Provisioning failed: A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.))

The error also keeps appearing in the Application Event Log as event ID 7888.

Google searches tell me its a connection between the Sharepoint server and the SQL server however, this is a production SQL Server which has several databases on it that do not experience any problems. These databases also include the Central Admin and Web Application databases for Sharepoint which are all working fine.

Any guidance would be greatly appreciated.

Thanks in advance.


Turns out that the problem was a firewall IPS between the SQL Server and the Sharepoint server. Evidently it was killing the packets returning to the Sharepoint server.

Wireshark pointed out the "Malformed Packets" coming from the SQL server and I showed this to the network team who found the problem right away. Once they put in the exception the SSP provisioned as it should have.


I have seen thuis error in a virtualized scenario where the host was overloaded and the traffic timed out. Moving to an ESX 4 system from VMware Server resolved the issue. Are the systems in your farm physical or virtual machines? Any other possible network issues between the systems if physical?

I have also found a few folks with the 7888 error that indicated an update of the NIC driver eliminated the error.

  • coincidentally this server is a virtual guest. However it's the only guest currently running on the host. I'll check the drivers on the guest and host and make sure they are up to date. – Tim Nov 17 '09 at 18:30
  • Is it on ESX or....? We had one VM, the SharePoint Web Front end, on a VMware server system and a RAID 5 array. There was only the host OS and the single SharePoint server and we still had 7888 errors. Moved to ESX4.0 and each VM on a RAID 1 array and errors gone. Same hardware, just ESX now and different drive arrays. Added the SQL backend and still no error and much better performance – Dave M Nov 17 '09 at 18:54
  • The Sharepoint frontend is a (gasp) Hyper-V guest. The SQL Server instance however is on a beefy physical cluster. I've just finished installing the updated NIC drivers to no avail the error is still occuring every minute. It's such an odd error. – Tim Nov 17 '09 at 19:05
  • Many folks struggle with this one from what my searches found. Any other load on the HyperV system? What happens if you PING from the front end to the SQL system. We found times went from <1ms to hundreds of ms. That was the clue we had a network bottleneck. Had to do it over about 15 minutes and look at avergae and loss and so on. – Dave M Nov 17 '09 at 19:34
  • Well that was the odd part about this. I ran a constant ping for a solid 5 minutes with hardly any fluctuations from <1ms, and like I said before there are other databases running just fine for this Sharepoint server. However... – Tim Nov 17 '09 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.