0

I've got a very weird error in a server. It is a Windows Server 2012 R2 Standard Domain Controller (primary) running in VMware ESXi 6.0 U2. It has DNS, DHCP and some file shares. The error is that it can't establish any outgoing TCP connection, neither local, lan or wan. Ping and UDP works fine (as it is DNS server, I see UDP DNS packets flowing in the firewall). Incoming connections works fine too. For example, if I do a telnet 127.0.0.1 3389 it doesn't anwser, I got the standard error message "Connecting To 127.0.0.1...Could not open connection to the host, on port 3389 : Connect failed", but I am connected to it through RDP.

For the record, no third-party anti-virus installed, I tested disabling the firewall, routes are normal, there are no signs of TCP port exhaustion (there are almost no connections above port 50000).

I don't know if its related, but I have a script which downloads a page daily, the command is powershell -ExecutionPolicy unrestricted -Command "(New-Object Net.WebClient).DownloadString(\"http://google.com\")" (with another url, obviously). When it runs, it gets a OutOfMemoryException, but the server is with 8 GB and only 2.9 GB in use.

Thanks in advance for all help provided.

7
  • 127.0.0.1 isn't technically an outbound connection. Can you tell us what happens if you try to open a website from the server, or telnet to an external ip address, etc.? – joeqwerty Jun 21 '17 at 13:16
  • Well, that's true, but a localhost connection is one that leaves and arrives at the same place, and the problem is in the leaving step.. The error is exactly the same error of the telnet to localhost. Just in case, I tried to connect to a secondary DC on 3389, which is working fine from any other machine. And telnet google.com 80 too, which works for every machine.. – Bruno Bragança Jun 21 '17 at 14:57
  • What is your routing table like (route print)? Have you tried running ping 8.8.8.8 or tracert -d 8.8.8.8 to test your outbound connections? – Pak Jun 21 '17 at 18:20
  • As said, ping and udp works fine.. a ping to 8.8.8.8 or google.com works, so we can discard routing problems.. but a telnet google.com 80 doesn't.. also telnet 127.0.0.1 3389 doesn't work too, so we can discard firewall problems.. very weird.. – Bruno Bragança Jun 21 '17 at 18:50
  • Just in case, I formatted the server. It took me 3 hours to bring it back online fully functional, which is nothing compared to the time I was losing researching this error and with a non-funcional server. Thanks for all your help. – Bruno Bragança Jun 22 '17 at 17:08
1

Just for the case that someone runs into the same issue. I had the problem that incoming -> everything was possible (TCP/IP, PING) Outgoing, only ICMP(PING) was possible, but no socket connect. It helped me to uninstall the last installed updates...

0

Not sure if this helps, but I had the same problem on a Windows Server 2012 R2 DataCenter Hyper-V host. ICMP worked fine, but not tcp. For example, telnet google.com 80 would fail on both the host and guest vms. It started happening after a windows update reboot. Uninstalling the updates did not fix anything. I finally fixed it by deleting all the virtual switches and rebuilding them.

1
  • Well, I don't know if that would help, as other vms at the same host were functioning normally and because the new vm solved the problem, I deleted it and created a new one, installed the Windows from scratch and recycled the secondary disks. Thanks by the way – Bruno Bragança Apr 30 '18 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.